p PatchFirst

CVE-2022-25377

CVE-2022-25377

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The ACME-challenge endpoint in Appwrite 0.5.0 through 0.12.x before 0.12.2 allows remote attackers to read arbitrary local files via ../ directory traversal. In order to be vulnerable, APP_STORAGE_CERTIFICATES/.well-known/acme-challenge must exist on disk. (This pathname is automatically created if the user chooses to install Let's Encrypt certificates via Appwrite.)

CVSS 7.5 · High · EPSS 0.8% · Fix available

Published
Updated

Stack: php

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • appwrite/server-ce Packagist

    Versions
    • 0.10.0
    • 0.10.1
    • 0.10.2
    • 0.10.3
    • 0.10.4
    • 0.11.0
    • 0.11.1
    • 0.11.2
    • 0.12.0
    • 0.12.1
    • 0.5.0
    • 0.5.1
    • 0.5.2
    • 0.5.3
    • 0.6.0
    • 0.6.1
    • 0.6.2
    • 0.7.0
    • 0.7.1
    • 0.7.2
    • 0.8.0
    • 0.9
    • 0.9.1
    • 0.9.2
    • 0.9.3
    • 0.9.4
    Affected ranges
    • ECOSYSTEM: ≥ 0.5.0, < 0.12.2

    Update to 0.12.2

Original sources

Check your server →