p PatchFirst

PatchFirst · Latest vulnerabilities

appwrite/server-ce vulnerabilities

Vulnerabilities published for appwrite/server-ce in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 4

  1. CVE-2022-25377

    High · CVSS 7.5EPSS 0.79%Fix available

    CVE-2022-25377

    The ACME-challenge endpoint in Appwrite 0.5.0 through 0.12.x before 0.12.2 allows remote attackers to read arbitrary local files via ../ directory traversal. In order to be vulnerable, APP_STORAGE_CERTIFICATES/.well-known/acme-challenge must exist on disk. (This pathname is automatically created if the user chooses to install Let's Encrypt certificates via Appwrite.)

    • Update to 0.12.2
    Published Updated
  2. CVE-2021-23682

    High · CVSS 7.3EPSS 2.12%Fix available

    Prototype Pollution

    This affects the package litespeed.js before 0.3.12; the package appwrite/server-ce from 0.12.0 and before 0.12.2, before 0.11.1. When parsing the query string in the getJsonFromUrl function, the key that is set in the result object is not properly sanitized leading to a Prototype Pollution vulnerability.

    • Update to 0.11.1
    • Update to 0.12.2
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →