p PatchFirst

CVE-2022-33099

CVE-2022-33099

This page contains facts from public vulnerability sources. Check the original advisory before updating.

An issue in the component luaG_runerror of Lua v5.4.4 and below leads to a heap-buffer overflow when a recursive error occurs.

CVSS 7.5 · High · EPSS 2.8% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • lua5.4 Debian:12

    Affected ranges
    • ECOSYSTEM: < 5.4.4-3

    Update to 5.4.4-3

  • lua5.4 Debian:13

    Affected ranges
    • ECOSYSTEM: < 5.4.4-3

    Update to 5.4.4-3

  • lua5.4 Debian:14

    Affected ranges
    • ECOSYSTEM: < 5.4.4-3

    Update to 5.4.4-3

  • lua5.4 Ubuntu:Pro:22.04:LTS

    Versions
    • 5.4.2-2
    • 5.4.3-1
    • 5.4.4-1
    Affected ranges
    • ECOSYSTEM: < 5.4.4-1ubuntu0.1~esm1

    Update to 5.4.4-1ubuntu0.1~esm1

Original sources

Check your server →