CVE-2022-33099
An issue in the component luaG_runerror of Lua v5.4.4 and below leads to a heap-buffer overflow when a recursive error occurs.
- Update to 5.4.4-1ubuntu0.1~esm1
Published Updated
PatchFirst · Latest vulnerabilities
Vulnerabilities published for lua5.4 in the last 30 days: 0. Listed in the KEV catalogue: 0.
Vulnerabilities: 2
An issue in the component luaG_runerror of Lua v5.4.4 and below leads to a heap-buffer overflow when a recursive error occurs.
singlevar in lparser.c in Lua from (including) 5.4.0 up to (excluding) 5.4.4 lacks a certain luaK_exp2anyregup call, leading to a heap-based buffer over-read that might affect a system that compiles untrusted Lua code.
Check your installed stack and versions against the current vulnerability feeds.