p PatchFirst

CVE-2022-35737

CVE-2022-35737

This page contains facts from public vulnerability sources. Check the original advisory before updating.

SQLite 1.0.12 through 3.39.x before 3.39.2 sometimes allows an array-bounds overflow if billions of bytes are used in a string argument to a C API.

CVSS 7.5 · High · EPSS 23.6% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • sqlite3 Debian:12

    Affected ranges
    • ECOSYSTEM: < 3.39.2-1

    Update to 3.39.2-1

  • sqlite3 Debian:13

    Affected ranges
    • ECOSYSTEM: < 3.39.2-1

    Update to 3.39.2-1

  • sqlite3 Debian:14

    Affected ranges
    • ECOSYSTEM: < 3.39.2-1

    Update to 3.39.2-1

  • sqlite3 Ubuntu:Pro:14.04:LTS

    Versions
    • 3.7.17-1ubuntu1
    • 3.8.0.2-1ubuntu1
    • 3.8.1-1ubuntu1
    • 3.8.1-1ubuntu3
    • 3.8.2-1ubuntu1
    • 3.8.2-1ubuntu2
    • 3.8.2-1ubuntu2.1
    • 3.8.2-1ubuntu2.2
    • 3.8.2-1ubuntu2.2+esm1
    • 3.8.2-1ubuntu2.2+esm2
    Affected ranges
    • ECOSYSTEM: < 3.8.2-1ubuntu2.2+esm3

    Update to 3.8.2-1ubuntu2.2+esm3

  • sqlite3 Ubuntu:Pro:16.04:LTS

    Versions
    • 3.8.11.1-1
    • 3.9.1-2
    • 3.9.2-1
    • 3.10.0-1
    • 3.10.1-1
    • 3.10.2-1
    • 3.11.0-1ubuntu1
    • 3.11.0-1ubuntu1.1
    • 3.11.0-1ubuntu1.2
    • 3.11.0-1ubuntu1.3
    • 3.11.0-1ubuntu1.4
    • 3.11.0-1ubuntu1.5
    • 3.11.0-1ubuntu1.5+esm1
    Affected ranges
    • ECOSYSTEM: < 3.11.0-1ubuntu1.5+esm2

    Update to 3.11.0-1ubuntu1.5+esm2

  • sqlite Ubuntu:16.04:LTS

    Versions
    • 2.8.17-12fakesync1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • sqlite3 Ubuntu:18.04:LTS

    Versions
    • 3.19.3-3
    • 3.20.1-2
    • 3.21.0-1
    • 3.22.0-1
    • 3.22.0-1ubuntu0.1
    • 3.22.0-1ubuntu0.2
    • 3.22.0-1ubuntu0.3
    • 3.22.0-1ubuntu0.4
    • 3.22.0-1ubuntu0.5
    • 3.22.0-1ubuntu0.6
    Affected ranges
    • ECOSYSTEM: < 3.22.0-1ubuntu0.7

    Update to 3.22.0-1ubuntu0.7

  • sqlite3 Ubuntu:20.04:LTS

    Versions
    • 3.29.0-2
    • 3.30.1-1
    • 3.30.1-1ubuntu1
    • 3.31.1-1ubuntu1
    • 3.31.1-3
    • 3.31.1-4
    • 3.31.1-4ubuntu0.1
    • 3.31.1-4ubuntu0.2
    • 3.31.1-4ubuntu0.3
    • 3.31.1-4ubuntu0.4
    Affected ranges
    • ECOSYSTEM: < 3.31.1-4ubuntu0.5

    Update to 3.31.1-4ubuntu0.5

  • sqlite3 Ubuntu:22.04:LTS

    Versions
    • 3.35.5-1
    • 3.36.0-2
    • 3.37.2-2
    Affected ranges
    • ECOSYSTEM: < 3.37.2-2ubuntu0.1

    Update to 3.37.2-2ubuntu0.1

Original sources

Check your server →