p PatchFirst

PatchFirst · Latest vulnerabilities

sqlite3 vulnerabilities

Vulnerabilities published for sqlite3 in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 11

  1. CVE-2026-39113

    Medium · CVSS 4EPSS 0.19%Public exploitFix available

    CVE-2026-39113

    Buffer Overflow vulnerability in SQLite affected version source snapshots/builds containing Fossil check-in 8bdc0d485e3ad0c7a1e818da66f106951d496b05cbe61d12c2c448f2f24b6d5d (Git mirror 169f68ed88b34cb68f720191c64c058f2ccec508, 2026-03-11) and later snapshots/builds allows an attacker to cause a denial of service via the ext/misc/sqlar.c, sqlarUncompressFunc(), sqlar_uncompress(), sqlite3_value_int64(), sqlite3_malloc(int), uncompress() components

    • Update to 3.37.2-2ubuntu0.8
    Published Updated
  2. CVE-2026-50812

    Medium · CVSS 5.5EPSS 0.16%Fix available

    CVE-2026-50812

    A NULL pointer dereference in the SQLite Session Extension in SQLite 3.53.1 and SQLite trunk builds before check-in e807d4e3798efd53 allows an attacker who can supply a malformed changeset blob to cause a denial of service. The issue occurs when sqlite3changeset_apply_v3() applies a corrupt changeset and reaches sqlite3_value_type() with a NULL sqlite3_value pointer.

    • Update to 3.37.2-2ubuntu0.7
    Published Updated
  3. CVE-2026-11824

    High · CVSS 8.5EPSS 0.18%Fix available

    SQLite before 3.53.2 Heap Buffer Overflow via FTS5 fts5ChunkIterate

    SQLite before 3.53.2 contains a heap-based buffer overflow vulnerability in the FTS5 full-text search extension that allows attackers to cause a crash or execute arbitrary code by supplying a crafted database with malicious continuation page metadata specifying a szLeaf value smaller than 4. Attackers can trigger an integer underflow in fts5ChunkIterate() causing an inflated remaining byte count during FTS5 MATCH query processing, leading to a heap buffer overflow of attacker-controlled data in applications compiled with SQLITE_ENABLE_FTS5.

    • Update to 3.37.2-2ubuntu0.6
    Published Updated
  4. CVE-2026-11822

    High · CVSS 8.5EPSS 0.36%Fix available

    SQLite before 3.53.2 Memory Corruption in FTS5 Extension

    SQLite before 3.53.2 contains memory corruption vulnerabilities in the FTS5 full-text search extension that allow attackers to cause process crashes, memory exhaustion, or arbitrary code execution by supplying a crafted database with malformed FTS5 page data. Attackers can trigger an out-of-bounds read in fts5LeafSeek() via an attacker-controlled loop bound and a heap buffer overflow write in fts5ChunkIterate() through a crafted continuation page causing an integer underflow, exploitable when an FTS5 MATCH query is executed against the malicious database.

    • Update to 3.37.2-2ubuntu0.6
    Published Updated
  5. CVE-2025-52099

    High · CVSS 7.5Fix available

    UBUNTU-CVE-2025-52099

    Rejected reason: DO NOT USE THIS CVE RECORD. ConsultIDs: CVE-2025-29088. Reason: This record is a duplicate of CVE-2025-29088. Notes: All CVE users should reference CVE-2025-29088 instead of this record. All references and descriptions in this record have been removed to prevent accidental usage.

    • Update to 3.37.2-2ubuntu0.4
    Published Updated
  6. CVE-2023-7104

    Medium · CVSS 5.5EPSS 1.46%Fix available

    SQLite SQLite3 make alltest sqlite3session.c sessionReadRecord heap-based overflow

    A vulnerability was found in SQLite SQLite3 up to 3.43.0 and classified as critical. This issue affects the function sessionReadRecord of the file ext/session/sqlite3session.c of the component make alltest Handler. The manipulation leads to heap-based buffer overflow. It is recommended to apply a patch to fix this issue. The associated identifier of this vulnerability is VDB-248999.

    • Update to 3.37.2-2ubuntu0.3
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →