CVE-2022-40023
CVE-2022-40023
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Sqlalchemy mako before 1.2.2 is vulnerable to Regular expression Denial of Service when using the Lexer class to parse. This also affects babelplugin and linguaplugin.
CVSS 8.7 · High · EPSS 2.2% · Fix available
- Published
- Updated
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
mako Debian:12
- Affected ranges
- ECOSYSTEM: < 1.2.2+ds1-1
Update to 1.2.2+ds1-1
mako Debian:13
- Affected ranges
- ECOSYSTEM: < 1.2.2+ds1-1
Update to 1.2.2+ds1-1
mako Debian:14
- Affected ranges
- ECOSYSTEM: < 1.2.2+ds1-1
Update to 1.2.2+ds1-1
mako PyPI
- Versions
- 0.1.0
- 0.1.1
- 0.1.10
- 0.1.2
- 0.1.3
- 0.1.4
- 0.1.5
- 0.1.6
- 0.1.7
- 0.1.8
- 0.1.9
- 0.2.0
- 0.2.1
- 0.2.2
- 0.2.3
- 0.2.4
- 0.2.5
- 0.3.0
- 0.3.1
- 0.3.2
- 0.3.3
- 0.3.4
- 0.3.5
- 0.3.6
- 0.4.0
- 0.4.1
- 0.4.2
- 0.5.0
- 0.6.0
- 0.6.1
- 0.6.2
- 0.7.0
- 0.7.1
- 0.7.2
- 0.7.3
- 0.8.0
- 0.8.1
- 0.9.0
- 0.9.1
- 1.0.0
- 1.0.1
- 1.0.10
- 1.0.11
- 1.0.12
- 1.0.13
- 1.0.14
- 1.0.2
- 1.0.3
- 1.0.4
- 1.0.5
- 1.0.6
- 1.0.7
- 1.0.8
- 1.0.9
- 1.1.0
- 1.1.1
- 1.1.2
- 1.1.3
- 1.1.4
- 1.1.5
- 1.1.6
- 1.2.0
- 1.2.1
- Affected ranges
- ECOSYSTEM: < 1.2.2
Update to 1.2.2
mako PyPI
- Versions
- 0.1.0
- 0.1.1
- 0.1.10
- 0.1.2
- 0.1.3
- 0.1.4
- 0.1.5
- 0.1.6
- 0.1.7
- 0.1.8
- 0.1.9
- 0.2.0
- 0.2.1
- 0.2.2
- 0.2.3
- 0.2.4
- 0.2.5
- 0.3.0
- 0.3.1
- 0.3.2
- 0.3.3
- 0.3.4
- 0.3.5
- 0.3.6
- 0.4.0
- 0.4.1
- 0.4.2
- 0.5.0
- 0.6.0
- 0.6.1
- 0.6.2
- 0.7.0
- 0.7.1
- 0.7.2
- 0.7.3
- 0.8.0
- 0.8.1
- 0.9.0
- 0.9.1
- 1.0.0
- 1.0.1
- 1.0.10
- 1.0.11
- 1.0.12
- 1.0.13
- 1.0.14
- 1.0.2
- 1.0.3
- 1.0.4
- 1.0.5
- 1.0.6
- 1.0.7
- 1.0.8
- 1.0.9
- 1.1.0
- 1.1.1
- 1.1.2
- 1.1.3
- 1.1.4
- 1.1.5
- 1.1.6
- 1.2.0
- 1.2.1
- Affected ranges
- GIT: < 925760291d6efec64fda6e9dd1fd9cfbd5be068c
- ECOSYSTEM: < 1.2.2
Update to 1.2.2
mako Ubuntu:Pro:16.04:LTS
- Versions
- 1.0.2+ds1-1
- 1.0.3+ds1-1
- 1.0.3+ds1-1ubuntu1
- Affected ranges
- ECOSYSTEM: < 1.0.3+ds1-1ubuntu1+esm1
Update to 1.0.3+ds1-1ubuntu1+esm1
mako Ubuntu:18.04:LTS
- Versions
- 1.0.7+ds1-1
- Affected ranges
- ECOSYSTEM: < 1.0.7+ds1-1ubuntu0.2
Update to 1.0.7+ds1-1ubuntu0.2
mako Ubuntu:20.04:LTS
- Versions
- 1.0.7+ds1-1
- 1.1.0+ds1-1
- 1.1.0+ds1-1ubuntu1
- 1.1.0+ds1-1ubuntu2
- Affected ranges
- ECOSYSTEM: < 1.1.0+ds1-1ubuntu2.1
Update to 1.1.0+ds1-1ubuntu2.1
mako Ubuntu:22.04:LTS
- Versions
- 1.1.3+ds1-2
- Affected ranges
- ECOSYSTEM: < 1.1.3+ds1-2ubuntu0.1
Update to 1.1.3+ds1-2ubuntu0.1
Original sources
- https://github.com/sqlalchemy/mako/issues/366
- https://github.com/sqlalchemy/mako/commit/925760291d6efec64fda6e9dd1fd9cfbd5be068c
- https://github.com/sqlalchemy/mako/blob/c2f392e0be52dc67d1b9770ab8cce6a9c736d547/mako/ext/extract.py#L21
- https://pyup.io/vulnerabilities/CVE-2022-40023/50870/
- https://lists.debian.org/debian-lts-announce/2022/09/msg00026.html
- https://pyup.io/posts/pyup-discovers-redos-vulnerabilities-in-top-python-packages/
- https://lists.debian.org/debian-lts-announce/2025/12/msg00004.html
- https://nvd.nist.gov/vuln/detail/CVE-2022-40023