p PatchFirst

CVE-2022-41409

CVE-2022-41409

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Integer overflow vulnerability in pcre2test before 10.41 allows attackers to cause a denial of service or other unspecified impacts via negative input.

CVSS 7.5 · High · EPSS 1.1% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • pcre2 Debian:12

    Affected ranges
    • ECOSYSTEM: < 10.42-1

    Update to 10.42-1

  • pcre2 Debian:13

    Affected ranges
    • ECOSYSTEM: < 10.42-1

    Update to 10.42-1

  • pcre2 Debian:14

    Affected ranges
    • ECOSYSTEM: < 10.42-1

    Update to 10.42-1

  • pcre2 Ubuntu:16.04:LTS

    Versions
    • 10.20-1
    • 10.20-2
    • 10.20-3
    • 10.21-1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • pcre2 Ubuntu:Pro:18.04:LTS

    Versions
    • 10.22-3
    • 10.22-4
    • 10.22-5
    • 10.22-6
    • 10.31-2
    • 10.31-2ubuntu0.1~esm1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • pcre2 Ubuntu:20.04:LTS

    Versions
    • 10.32-5
    • 10.34-7
    • 10.34-7ubuntu0.1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • pcre2 Ubuntu:22.04:LTS

    Versions
    • 10.37-0ubuntu2
    • 10.39-3
    • 10.39-3build1
    • 10.39-3ubuntu0.1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →