p PatchFirst

PatchFirst · Latest vulnerabilities

pcre2 vulnerabilities

Vulnerability published for pcre2 in the last 30 days: 1. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 14

  1. CVE-2026-86145

    High · CVSS 8.2EPSS 0.43%Fix available

    CVE-2026-86145

    PCRE2 before 10.48 allows a pcre2_dfa_match out-of-bounds write because reuse of a cached workspace block, in a recursive DFA matching workspace, lacks a size check (even though a newly allocated block, for the same purpose, does have a size check). This outcome requires an attacker-controlled regular expression, or a recursive pattern in conjunction with a small heap limit (this can be set through the API).

    • Update to 10.42-1+deb12u1
    Published Updated
  2. CVE-2022-1586

    Critical · CVSS 9.1EPSS 3.37%Fix available

    CVE-2022-1586

    An out-of-bounds read vulnerability was discovered in the PCRE2 library in the compile_xclass_matchingpath() function of the pcre2_jit_compile.c file. This involves a unicode property matching issue in JIT-compiled regular expressions. The issue occurs because the character was not fully read in case-less matching within JIT.

    • Update to 10.40-1
    Published Updated
  3. CVE-2019-20454

    Medium · CVSS 5.1EPSS 1.56%Fix available

    CVE-2019-20454

    An out-of-bounds read was discovered in PCRE before 10.34 when the pattern \X is JIT compiled and used to match specially crafted subjects in non-UTF mode. Applications that use PCRE to parse untrusted input may be vulnerable to this flaw, which would allow an attacker to crash the application. The flaw occurs in do_extuni_no_utf in pcre2_jit_compile.c.

    • Update to 10.34-1
    Published Updated
  4. CVE-2016-3191

    Critical · CVSS 9.8EPSS 8.43%Fix available

    CVE-2016-3191

    The compile_branch function in pcre_compile.c in PCRE 8.x before 8.39 and pcre2_compile.c in PCRE2 before 10.22 mishandles patterns containing an (*ACCEPT) substring in conjunction with nested parentheses, which allows remote attackers to execute arbitrary code or cause a denial of service (stack-based buffer overflow) via a crafted regular expression, as demonstrated by a JavaScript RegExp object encountered by Konqueror, aka ZDI-CAN-3542.

    • Update to 10.21-1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →