CVE-2022-41974
CVE-2022-41974
This page contains facts from public vulnerability sources. Check the original advisory before updating.
multipath-tools 0.7.0 through 0.9.x before 0.9.2 allows local users to obtain root access, as exploited alone or in conjunction with CVE-2022-41973. Local users able to write to UNIX domain sockets can bypass access controls and manipulate the multipath setup. This can lead to local privilege escalation to root. This occurs because an attacker can repeat a keyword, which is mishandled because arithmetic ADD is used instead of bitwise OR.
CVSS 7.8 · High · EPSS 0.6% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
multipath-tools Debian:12
- Affected ranges
- ECOSYSTEM: < 0.9.4-1
Update to 0.9.4-1
multipath-tools Debian:13
- Affected ranges
- ECOSYSTEM: < 0.9.4-1
Update to 0.9.4-1
multipath-tools Debian:14
- Affected ranges
- ECOSYSTEM: < 0.9.4-1
Update to 0.9.4-1
multipath-tools Ubuntu:14.04:LTS
- Versions
- 0.4.9-3ubuntu7
- 0.4.9-3ubuntu7.2
- 0.4.9-3ubuntu7.4
- 0.4.9-3ubuntu7.6
- 0.4.9-3ubuntu7.7
- 0.4.9-3ubuntu7.9
- 0.4.9-3ubuntu7.11
- 0.4.9-3ubuntu7.12
- 0.4.9-3ubuntu7.13
- 0.4.9-3ubuntu7.14
- 0.4.9-3ubuntu7.15
- 0.4.9-3ubuntu7.16
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
multipath-tools Ubuntu:16.04:LTS
- Versions
- 0.5.0-7ubuntu7
- 0.5.0-7ubuntu8
- 0.5.0-7ubuntu9
- 0.5.0-7ubuntu10
- 0.5.0-7ubuntu11
- 0.5.0-7ubuntu12
- 0.5.0-7ubuntu14
- 0.5.0-7ubuntu15
- 0.5.0-7ubuntu16
- 0.5.0+git1.656f8865-5ubuntu1
- 0.5.0+git1.656f8865-5ubuntu2
- 0.5.0+git1.656f8865-5ubuntu2.1
- 0.5.0+git1.656f8865-5ubuntu2.2
- 0.5.0+git1.656f8865-5ubuntu2.3
- 0.5.0+git1.656f8865-5ubuntu2.4
- 0.5.0+git1.656f8865-5ubuntu2.5
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
multipath-tools Ubuntu:18.04:LTS
- Versions
- 0.6.4-5ubuntu1
- 0.7.4-2ubuntu1
- 0.7.4-2ubuntu3
- 0.7.4-2ubuntu3.1
- Affected ranges
- ECOSYSTEM: < 0.7.4-2ubuntu3.2
Update to 0.7.4-2ubuntu3.2
multipath-tools Ubuntu:20.04:LTS
- Versions
- 0.7.9-3ubuntu6
- 0.7.9-3ubuntu7
- 0.8.3-1ubuntu1
- 0.8.3-1ubuntu2
- Affected ranges
- ECOSYSTEM: < 0.8.3-1ubuntu2.1
Update to 0.8.3-1ubuntu2.1
multipath-tools Ubuntu:22.04:LTS
- Versions
- 0.8.5-2ubuntu2
- 0.8.5-2ubuntu3
- 0.8.8-1ubuntu1
- Affected ranges
- ECOSYSTEM: < 0.8.8-1ubuntu1.22.04.1
Update to 0.8.8-1ubuntu1.22.04.1
Original sources
- https://bugzilla.suse.com/show_bug.cgi?id=1202739
- https://github.com/opensvc/multipath-tools/releases/tag/0.9.2
- http://www.openwall.com/lists/oss-security/2022/10/24/2
- http://seclists.org/fulldisclosure/2022/Oct/25
- http://packetstormsecurity.com/files/169611/Leeloo-Multipath-Authorization-Bypass-Symlink-Attack.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/QIGZM5NOOMFDCITOLQEJNNX5SCRQLQVV/
- https://www.qualys.com/2022/10/24/leeloo-multipath/leeloo-multipath.txt
- http://www.openwall.com/lists/oss-security/2022/11/30/2
- http://seclists.org/fulldisclosure/2022/Dec/4
- http://packetstormsecurity.com/files/170176/snap-confine-must_mkdir_and_open_with_perms-Race-Condition.html
- https://lists.debian.org/debian-lts-announce/2022/12/msg00037.html
- https://www.debian.org/security/2023/dsa-5366
- https://security.gentoo.org/glsa/202311-06
- https://nvd.nist.gov/vuln/detail/CVE-2022-41974