p PatchFirst

PatchFirst · Latest vulnerabilities

multipath-tools vulnerabilities

Vulnerabilities published for multipath-tools in the last 30 days: 1. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 4

  1. CVE-2026-114038

    Medium · CVSS 5.1EPSS 0.12%No fix published

    Device-mapper-multipath: device-mapper-multipath: information disclosure via malformed format string

    A flaw was found in device-mapper-multipath. A local user can trigger an out-of-bounds read by sending a command with a format string ending in a trailing percent character to the multipath daemon. This issue can allow the user to expose unintended daemon memory, leading to information disclosure, or cause the daemon to crash, resulting in a Denial of Service (DoS).

    Published Updated
  2. CVE-2026-89329

    Medium · CVSS 6.2EPSS 0.16%No fix published

    Device-mapper-multipath: local denial of service via blocking ipc send operations

    A flaw was found in `multipathd`. A local attacker with access to the `multipathd` UNIX control socket can exploit this vulnerability by sending valid commands and then ceasing to read replies. This action can cause the `multipathd` listener thread to block, leading to a Denial of Service (DoS) where legitimate Inter-Process Communication (IPC) operations may hang or time out. This issue does not result in privilege escalation, arbitrary code execution, or impact data confidentiality or integrity.

    Published Updated
  3. CVE-2022-41974

    High · CVSS 7.8EPSS 0.63%Fix available

    CVE-2022-41974

    multipath-tools 0.7.0 through 0.9.x before 0.9.2 allows local users to obtain root access, as exploited alone or in conjunction with CVE-2022-41973. Local users able to write to UNIX domain sockets can bypass access controls and manipulate the multipath setup. This can lead to local privilege escalation to root. This occurs because an attacker can repeat a keyword, which is mishandled because arithmetic ADD is used instead of bitwise OR.

    • Update to 0.8.8-1ubuntu1.22.04.1
    Published Updated
  4. CVE-2022-41973

    High · CVSS 7.8EPSS 0.68%Fix available

    CVE-2022-41973

    multipath-tools 0.7.7 through 0.9.x before 0.9.2 allows local users to obtain root access, as exploited in conjunction with CVE-2022-41974. Local users able to access /dev/shm can change symlinks in multipathd due to incorrect symlink handling, which could lead to controlled file writes outside of the /dev/shm directory. This could be used indirectly for local privilege escalation to root.

    • Update to 0.8.8-1ubuntu1.22.04.1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →