CVE-2022-4254
CVE-2022-4254
This page contains facts from public vulnerability sources. Check the original advisory before updating.
sssd: libsss_certmap fails to sanitise certificate data used in LDAP filters
CVSS 8.8 · High · EPSS 0.9% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
sssd
- Versions
- Affects SSSD 1.15.3, Fixed in SSSD 2.3.1: Affected
No fix published
sssd Debian:12
- Affected ranges
- ECOSYSTEM: < 2.3.1-1
Update to 2.3.1-1
sssd Debian:13
- Affected ranges
- ECOSYSTEM: < 2.3.1-1
Update to 2.3.1-1
sssd Ubuntu:Pro:18.04:LTS
- Versions
- 1.15.3-2ubuntu1
- 1.15.3-3ubuntu1
- 1.16.0-5ubuntu1
- 1.16.0-5ubuntu2
- 1.16.1-1ubuntu1
- 1.16.1-1ubuntu1.1
- 1.16.1-1ubuntu1.2
- 1.16.1-1ubuntu1.3
- 1.16.1-1ubuntu1.4
- 1.16.1-1ubuntu1.5
- 1.16.1-1ubuntu1.6
- 1.16.1-1ubuntu1.7
- 1.16.1-1ubuntu1.8
- 1.16.1-1ubuntu1.8+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
sssd Ubuntu:20.04:LTS
- Versions
- 2.2.0-4ubuntu1
- 2.2.2-1
- 2.2.2-1ubuntu1
- 2.2.3-1.1ubuntu1
- 2.2.3-2
- 2.2.3-3
- 2.2.3-3ubuntu0.1
- 2.2.3-3ubuntu0.2
- 2.2.3-3ubuntu0.3
- 2.2.3-3ubuntu0.4
- 2.2.3-3ubuntu0.6
- 2.2.3-3ubuntu0.7
- 2.2.3-3ubuntu0.8
- 2.2.3-3ubuntu0.9
- 2.2.3-3ubuntu0.10
- Affected ranges
- ECOSYSTEM: < 2.2.3-3ubuntu0.11
Update to 2.2.3-3ubuntu0.11
Original sources
- https://bugzilla.redhat.com/show_bug.cgi?id=2149894
- https://github.com/SSSD/sssd/issues/5135
- https://github.com/SSSD/sssd/commit/a2b9a84460429181f2a4fa7e2bb5ab49fd561274
- https://access.redhat.com/security/cve/CVE-2022-4254
- https://lists.debian.org/debian-lts-announce/2023/05/msg00028.html
- https://nvd.nist.gov/vuln/detail/CVE-2022-4254