CVE-2022-46908
CVE-2022-46908
This page contains facts from public vulnerability sources. Check the original advisory before updating.
SQLite through 3.40.0, when relying on --safe for execution of an untrusted CLI script, does not properly implement the azProhibitedFunctions protection mechanism, and instead allows UDF functions such as WRITEFILE.
CVSS 7.3 · High · EPSS 0.4% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
sqlite3 Debian:12
- Affected ranges
- ECOSYSTEM: < 3.40.0-2
Update to 3.40.0-2
sqlite3 Debian:13
- Affected ranges
- ECOSYSTEM: < 3.40.0-2
Update to 3.40.0-2
sqlite3 Debian:14
- Affected ranges
- ECOSYSTEM: < 3.40.0-2
Update to 3.40.0-2
sqlite3 Ubuntu:22.04:LTS
- Versions
- 3.35.5-1
- 3.36.0-2
- 3.37.2-2
- 3.37.2-2ubuntu0.1
- Affected ranges
- ECOSYSTEM: < 3.37.2-2ubuntu0.3
Update to 3.37.2-2ubuntu0.3
Original sources
- https://news.ycombinator.com/item?id=33948588
- https://sqlite.org/forum/forumpost/07beac8056151b2f
- https://sqlite.org/src/info/cefc032473ac5ad2
- https://security.netapp.com/advisory/ntap-20230203-0005/
- https://security.gentoo.org/glsa/202311-03
- https://cert-portal.siemens.com/productcert/html/ssa-398330.html
- https://cert-portal.siemens.com/productcert/html/ssa-556635.html
- https://nvd.nist.gov/vuln/detail/CVE-2022-46908