p PatchFirst

CVE-2023-27604

CVE-2023-27604 · Apache Airflow Sqoop Provider: Airflow Sqoop Provider RCE Vulnerability

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Apache Airflow Sqoop Provider, versions before 4.0.0, is affected by a vulnerability that allows an attacker pass parameters with the connections, which makes it possible to implement RCE attacks via ‘sqoop import --connect’, obtain airflow server permissions, etc. The attacker needs to be logged in and have authorization (permissions) to create/edit connections. It is recommended to upgrade to a version that is not affected. This issue was reported independently by happyhacking-k, And Xie Jianming and LiuHui of Caiji Sec Team also reported it.

CVSS 8.8 · High · EPSS 1.7% · Fix available

Published
Updated

Stack: python

Affected products and versions

  • apache airflow sqoop provider

    Versions
    • ≥ 0, < 4.0.0: Affected (semver)

    Update to 4.0.0

  • apache-airflow-providers-apache-sqoop PyPI

    Versions
    • 1.0.0
    • 1.0.0b1
    • 1.0.0b2
    • 1.0.0rc1
    • 1.0.1
    • 1.0.1rc1
    • 2.0.0
    • 2.0.0rc1
    • 2.0.0rc2
    • 2.0.1
    • 2.0.1rc1
    • 2.0.1rc2
    • 2.0.2
    • 2.0.2rc1
    • 2.1.0
    • 2.1.0rc1
    • 2.1.0rc2
    • 2.1.1
    • 2.1.1rc1
    • 2.1.2
    • 2.1.2rc1
    • 2.1.3
    • 2.1.3rc1
    • 3.0.0
    • 3.0.0rc1
    • 3.0.0rc2
    • 3.1.0
    • 3.1.0rc1
    • 3.1.1
    • 3.1.1rc1
    • 3.2.0
    • 3.2.0rc1
    • 3.2.0rc2
    • 3.2.1
    • 3.2.1rc1
    • 4.0.0rc1
    Affected ranges
    • ECOSYSTEM: < 4.0.0

    Update to 4.0.0

Original sources

Check your server →