p PatchFirst

PatchFirst · Latest vulnerabilities

apache-airflow-providers-apache-sqoop vulnerabilities

Vulnerabilities published for apache-airflow-providers-apache-sqoop in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 2

  1. CVE-2023-27604

    High · CVSS 8.8EPSS 1.65%Fix available

    Apache Airflow Sqoop Provider: Airflow Sqoop Provider RCE Vulnerability

    Apache Airflow Sqoop Provider, versions before 4.0.0, is affected by a vulnerability that allows an attacker pass parameters with the connections, which makes it possible to implement RCE attacks via ‘sqoop import --connect’, obtain airflow server permissions, etc. The attacker needs to be logged in and have authorization (permissions) to create/edit connections. It is recommended to upgrade to a version that is not affected. This issue was reported independently by happyhacking-k, And Xie Jianming and LiuHui of Caiji Sec Team also reported it.

    • Update to 4.0.0
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →