p PatchFirst

CVE-2023-28095

CVE-2023-28095 · OpenSIPS has vulnerability in the building the local negative replies

This page contains facts from public vulnerability sources. Check the original advisory before updating.

OpenSIPS is a Session Initiation Protocol (SIP) server implementation. Versions prior to 3.1.7 and 3.2.4 have a potential issue in `msg_translator.c:2628` which might lead to a server crash. This issue was found while fuzzing the function `build_res_buf_from_sip_req` but could not be reproduced against a running instance of OpenSIPS. This issue could not be exploited against a running instance of OpenSIPS since no public function was found to make use of this vulnerable code. Even in the case of exploitation through unknown vectors, it is highly unlikely that this issue would lead to anything other than Denial of Service. This issue has been fixed in versions 3.1.7 and 3.2.4.

CVSS 7.5 · High · EPSS 1.0%

Published
Updated

Stack: system

Affected products and versions

  • opensips

    Versions
    • < 3.1.7: Affected
    • >= 3.2.0, < 3.2.4: Affected

    No fix published

  • opensips Ubuntu:18.04:LTS

    Versions
    • 2.2.2-3build2
    • 2.2.2-3build3
    • 2.2.2-3build4
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →