CVE-2023-28707
CVE-2023-28707 · Airflow Apache Drill Provider Arbitrary File Read Vulnerability
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Improper Input Validation vulnerability in Apache Software Foundation Apache Airflow Drill Provider.This issue affects Apache Airflow Drill Provider: before 2.3.2.
CVSS 7.5 · High · EPSS 2.1% · Fix available
- Published
- Updated
Stack: python
Affected products and versions
apache airflow drill provider
- Versions
- ≥ 0, < 2.3.2: Affected (semver)
Update to 2.3.2
apache-airflow-providers-apache-drill PyPI
- Versions
- 1.0.0
- 1.0.0rc1
- 1.0.0rc2
- 1.0.1
- 1.0.1rc1
- 1.0.2
- 1.0.2rc1
- 1.0.3
- 1.0.3rc1
- 1.0.4
- 1.0.4rc1
- 2.0.0
- 2.0.0rc1
- 2.0.0rc2
- 2.1.0
- 2.1.0rc1
- 2.2.0
- 2.2.0rc1
- 2.2.0rc2
- 2.2.0rc3
- 2.2.1
- 2.2.1rc1
- 2.3.0
- 2.3.0rc1
- 2.3.1
- 2.3.1rc2
- 2.3.1rc3
- 2.3.2rc1
- Affected ranges
- ECOSYSTEM: < 2.3.2
Update to 2.3.2
apache-airflow PyPI
- Versions
- 1.10.0
- 1.10.1
- 1.10.10
- 1.10.10rc1
- 1.10.10rc2
- 1.10.10rc3
- 1.10.10rc4
- 1.10.10rc5
- 1.10.11
- 1.10.11rc1
- 1.10.11rc2
- 1.10.12
- 1.10.12rc1
- 1.10.12rc2
- 1.10.12rc3
- 1.10.12rc4
- 1.10.13
- 1.10.13rc1
- 1.10.14
- 1.10.14rc1
- 1.10.14rc2
- 1.10.14rc3
- 1.10.14rc4
- 1.10.15
- 1.10.15rc1
- 1.10.1b1
- 1.10.1rc2
- 1.10.2
- 1.10.2b2
- 1.10.2rc1
- 1.10.2rc2
- 1.10.2rc3
- 1.10.3
- 1.10.3b1
- 1.10.3b2
- 1.10.3rc1
- 1.10.3rc2
- 1.10.4
- 1.10.4b2
- 1.10.4rc1
- 1.10.4rc2
- 1.10.4rc3
- 1.10.4rc4
- 1.10.4rc5
- 1.10.5
- 1.10.5rc1
- 1.10.6
- 1.10.6rc1
- 1.10.6rc2
- 1.10.7
- 1.10.7rc1
- 1.10.7rc2
- 1.10.7rc3
- 1.10.8
- 1.10.8rc1
- 1.10.9
- 1.10.9rc1
- 1.8.1
- 1.8.2
- 1.8.2rc1
- 1.9.0
- 2.0.0
- 2.0.0b1
- 2.0.0b2
- 2.0.0b3
- 2.0.0rc1
- 2.0.0rc2
- 2.0.0rc3
- 2.0.1
- 2.0.1rc1
- 2.0.1rc2
- 2.0.2
- 2.0.2rc1
- 2.1.0
- 2.1.0rc1
- 2.1.0rc2
- 2.1.1
- 2.1.1rc1
- 2.1.2
- 2.1.2rc1
- 2.1.3
- 2.1.3rc1
- 2.1.4
- 2.1.4rc1
- 2.1.4rc2
- 2.2.0
- 2.2.0b1
- 2.2.0b2
- 2.2.0rc1
- 2.2.1
- 2.2.1rc1
- 2.2.1rc2
- 2.2.2
- 2.2.2rc1
- 2.2.2rc2
- 2.2.3
- 2.2.3rc1
- 2.2.3rc2
- 2.2.4
- 2.2.4rc1
- 2.2.5
- 2.2.5rc1
- 2.2.5rc2
- 2.2.5rc3
- 2.3.0
- 2.3.0b1
- 2.3.0rc1
- 2.3.0rc2
- 2.3.1
- 2.3.1rc1
- 2.3.2rc1
- 2.3.2rc2
- Affected ranges
- ECOSYSTEM: < 2.3.2
Update to 2.3.2