p PatchFirst

PatchFirst · Latest vulnerabilities

apache-airflow-providers-apache-drill vulnerabilities

Vulnerabilities published for apache-airflow-providers-apache-drill in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 2

  1. CVE-2023-39553

    High · CVSS 7.5EPSS 2.28%Fix available

    Apache Airflow Drill Provider Arbitrary File Read Vulnerability

    Improper Input Validation vulnerability in Apache Software Foundation Apache Airflow Drill Provider. Apache Airflow Drill Provider is affected by a vulnerability that allows an attacker to pass in malicious parameters when establishing a connection with DrillHook giving an opportunity to read files on the Airflow server. This issue affects Apache Airflow Drill Provider: before 2.4.3. It is recommended to upgrade to a version that is not affected.

    • Update to 2.4.3
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →