CVE-2023-32643
CVE-2023-32643
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A flaw was found in GLib. The GVariant deserialization code is vulnerable to a heap buffer overflow introduced by the fix for CVE-2023-32665. This bug does not affect any released version of GLib, but does affect GLib distributors who followed the guidance of GLib developers to backport the initial fix for CVE-2023-32665.
CVSS 5.3 · Medium · EPSS 0.4% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
glib
- Versions
- 2.75.1: Not affected
No fix published
glib2.0 Ubuntu:Pro:14.04:LTS
- Versions
- 2.38.0-1ubuntu1
- 2.38.1-1
- 2.39.1-0ubuntu1
- 2.39.1-0ubuntu2
- 2.39.1-0ubuntu3
- 2.39.2-0ubuntu1
- 2.39.2-0ubuntu2
- 2.39.3-0ubuntu4
- 2.39.4-0ubuntu1
- 2.39.90-0ubuntu1
- 2.39.91-0ubuntu2
- 2.39.91-0ubuntu3
- 2.39.92-2
- 2.40.0-1
- 2.40.0-1ubuntu1
- 2.40.0-2
- 2.40.2-0ubuntu1
- 2.40.2-0ubuntu1.1
- 2.40.2-0ubuntu1.1+esm1
- 2.40.2-0ubuntu1.1+esm2
- 2.40.2-0ubuntu1.1+esm3
- 2.40.2-0ubuntu1.1+esm4
- Affected ranges
- ECOSYSTEM: < 2.40.2-0ubuntu1.1+esm6
Update to 2.40.2-0ubuntu1.1+esm6
glib2.0 Ubuntu:Pro:16.04:LTS
- Versions
- 2.46.1-1
- 2.46.1-2
- 2.47.1-1
- 2.47.3-3
- 2.47.4-1
- 2.47.5-1
- 2.47.6-1
- 2.48.0-1ubuntu3
- 2.48.0-1ubuntu4
- 2.48.1-1~ubuntu16.04.1
- 2.48.2-0ubuntu1
- 2.48.2-0ubuntu3
- 2.48.2-0ubuntu4
- 2.48.2-0ubuntu4.1
- 2.48.2-0ubuntu4.2
- 2.48.2-0ubuntu4.3
- 2.48.2-0ubuntu4.4
- 2.48.2-0ubuntu4.5
- 2.48.2-0ubuntu4.6
- 2.48.2-0ubuntu4.7
- 2.48.2-0ubuntu4.8
- 2.48.2-0ubuntu4.8+esm1
- Affected ranges
- ECOSYSTEM: < 2.48.2-0ubuntu4.8+esm3
Update to 2.48.2-0ubuntu4.8+esm3
glib2.0 Ubuntu:Pro:18.04:LTS
- Versions
- 2.54.1-1ubuntu1
- 2.55.2-2ubuntu1
- 2.56.0-2ubuntu1
- 2.56.0-4ubuntu1
- 2.56.1-2ubuntu1
- 2.56.2-0ubuntu0.18.04.1
- 2.56.2-0ubuntu0.18.04.2
- 2.56.3-0ubuntu0.18.04.1
- 2.56.4-0ubuntu0.18.04.2
- 2.56.4-0ubuntu0.18.04.3
- 2.56.4-0ubuntu0.18.04.4
- 2.56.4-0ubuntu0.18.04.5
- 2.56.4-0ubuntu0.18.04.6
- 2.56.4-0ubuntu0.18.04.7
- 2.56.4-0ubuntu0.18.04.8
- 2.56.4-0ubuntu0.18.04.9
- Affected ranges
- ECOSYSTEM: < 2.56.4-0ubuntu0.18.04.9+esm3
Update to 2.56.4-0ubuntu0.18.04.9+esm3
glib2.0 Ubuntu:20.04:LTS
- Versions
- 2.62.1-1
- 2.63.1-2
- 2.63.1-2ubuntu1
- 2.63.3-1
- 2.63.3-3
- 2.63.5-2
- 2.64.0-1
- 2.64.1-1
- 2.64.2-1~fakesync1
- 2.64.3-1~ubuntu20.04.1
- 2.64.6-1~ubuntu20.04.1
- 2.64.6-1~ubuntu20.04.2
- 2.64.6-1~ubuntu20.04.3
- 2.64.6-1~ubuntu20.04.4
- Affected ranges
- ECOSYSTEM: < 2.64.6-1~ubuntu20.04.6
Update to 2.64.6-1~ubuntu20.04.6
glib2.0 Ubuntu:22.04:LTS
- Versions
- 2.68.4-1ubuntu1
- 2.70.1-1
- 2.70.2-1
- 2.71.0-2
- 2.71.1-1
- 2.71.2-1
- 2.71.3-1
- 2.72.0-1
- 2.72.1-1
- 2.72.4-0ubuntu1
- 2.72.4-0ubuntu2
- Affected ranges
- ECOSYSTEM: < 2.72.4-0ubuntu2.2
Update to 2.72.4-0ubuntu2.2
Original sources
- https://gitlab.gnome.org/GNOME/glib/-/issues/2840
- https://https://discourse.gnome.org/t/multiple-fixes-for-gvariant-normalisation-issues-in-glib/12835
- https://security.netapp.com/advisory/ntap-20240426-0005/
- https://cert-portal.siemens.com/productcert/html/ssa-398330.html
- https://nvd.nist.gov/vuln/detail/CVE-2023-32643