p PatchFirst

PatchFirst · Latest vulnerabilities

glib2.0 vulnerabilities

Vulnerabilities published for glib2.0 in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 13

  1. CVE-2025-4373

    Medium · CVSS 4.8EPSS 0.64%Fix available

    Glib: buffer underflow on glib through glib/gstring.c via function g_string_insert_unichar

    A flaw was found in GLib, which is vulnerable to an integer overflow in the g_string_insert_unichar() function. When the position at which to insert the character is large, the position will overflow, leading to a buffer underwrite.

    • Update to 2.64.6-1~ubuntu20.04.9
    Published Updated
  2. CVE-2024-34397

    Medium · CVSS 5.2EPSS 0.76%Fix available

    CVE-2024-34397

    An issue was discovered in GNOME GLib before 2.78.5, and 2.79.x and 2.80.x before 2.80.1. When a GDBus-based client subscribes to signals from a trusted system service such as NetworkManager on a shared computer, other users of the same computer can send spoofed D-Bus signals that the GDBus-based client will wrongly interpret as having been sent by the trusted system service. This could lead to the GDBus-based client behaving incorrectly, with an application-dependent impact.

    • Update to 2.64.6-1~ubuntu20.04.7
    Published Updated
  3. CVE-2023-32636

    Medium · CVSS 4.7EPSS 0.79%Fix available

    CVE-2023-32636

    A flaw was found in glib, where the gvariant deserialization code is vulnerable to a denial of service introduced by additional input validation added to resolve CVE-2023-29499. The offset table validation may be very slow. This bug does not affect any released version of glib but does affect glib distributors who followed the guidance of glib developers to backport the initial fix for CVE-2023-29499.

    • Update to 2.64.6-1~ubuntu20.04.6
    Published Updated
  4. CVE-2023-32643

    Medium · CVSS 5.3EPSS 0.38%Fix available

    CVE-2023-32643

    A flaw was found in GLib. The GVariant deserialization code is vulnerable to a heap buffer overflow introduced by the fix for CVE-2023-32665. This bug does not affect any released version of GLib, but does affect GLib distributors who followed the guidance of GLib developers to backport the initial fix for CVE-2023-32665.

    • Update to 2.64.6-1~ubuntu20.04.6
    Published Updated
  5. CVE-2021-28153

    Medium · CVSS 5.3EPSS 2.71%Fix available

    CVE-2021-28153

    An issue was discovered in GNOME GLib before 2.66.8. When g_file_replace() is used with G_FILE_CREATE_REPLACE_DESTINATION to replace a path that is a dangling symlink, it incorrectly also creates the target of the symlink as an empty file, which could conceivably have security relevance if the symlink is attacker-controlled. (If the path is a symlink to a file that already exists, then the contents of that file correctly remain unchanged.)

    • Update to 2.64.6-1~ubuntu20.04.3
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →