p PatchFirst

CVE-2023-36664

CVE-2023-36664

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Artifex Ghostscript before 10.01.2 mishandles permission validation for pipe devices (with the %pipe% prefix or the | pipe character prefix).

CVSS 7.8 · High · EPSS 3.9% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • ghostscript Debian:12

    Versions
    • 10.0.0~dfsg-11
    Affected ranges
    • ECOSYSTEM: < 10.0.0~dfsg-11+deb12u1

    Update to 10.0.0~dfsg-11+deb12u1

  • ghostscript Debian:13

    Affected ranges
    • ECOSYSTEM: < 10.01.2~dfsg-1

    Update to 10.01.2~dfsg-1

  • ghostscript Debian:14

    Affected ranges
    • ECOSYSTEM: < 10.01.2~dfsg-1

    Update to 10.01.2~dfsg-1

  • ghostscript Ubuntu:20.04:LTS

    Versions
    • 9.27~dfsg+0-0ubuntu3
    • 9.27~dfsg+0-0ubuntu4
    • 9.50~dfsg-5ubuntu1
    • 9.50~dfsg-5ubuntu2
    • 9.50~dfsg-5ubuntu3
    • 9.50~dfsg-5ubuntu4
    • 9.50~dfsg-5ubuntu4.1
    • 9.50~dfsg-5ubuntu4.2
    • 9.50~dfsg-5ubuntu4.3
    • 9.50~dfsg-5ubuntu4.4
    • 9.50~dfsg-5ubuntu4.5
    • 9.50~dfsg-5ubuntu4.6
    • 9.50~dfsg-5ubuntu4.7
    Affected ranges
    • ECOSYSTEM: < 9.50~dfsg-5ubuntu4.8

    Update to 9.50~dfsg-5ubuntu4.8

  • ghostscript Ubuntu:22.04:LTS

    Versions
    • 9.54.0~dfsg1-0ubuntu2
    • 9.55.0~dfsg1-0ubuntu4
    • 9.55.0~dfsg1-0ubuntu5
    • 9.55.0~dfsg1-0ubuntu5.1
    • 9.55.0~dfsg1-0ubuntu5.2
    Affected ranges
    • ECOSYSTEM: < 9.55.0~dfsg1-0ubuntu5.3

    Update to 9.55.0~dfsg1-0ubuntu5.3

Original sources

Check your server →