p PatchFirst

PatchFirst · Latest vulnerabilities

ghostscript vulnerabilities

Vulnerabilities published for ghostscript in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 50

  1. CVE-2024-33871

    High · CVSS 8.8EPSS 1.43%Fix available

    CVE-2024-33871

    An issue was discovered in Artifex Ghostscript before 10.03.1. contrib/opvp/gdevopvp.c allows arbitrary code execution via a custom Driver library, exploitable via a crafted PostScript document. This occurs because the Driver parameter for opvp (and oprp) devices can have an arbitrary name for a dynamic library; this library is then loaded.

    • Update to 9.50~dfsg-5ubuntu4.12
    Published Updated
  2. CVE-2024-33870

    Medium · CVSS 6.3EPSS 0.52%Fix available

    CVE-2024-33870

    An issue was discovered in Artifex Ghostscript before 10.03.1. There is path traversal (via a crafted PostScript document) to arbitrary files if the current directory is in the permitted paths. For example, there can be a transformation of ../../foo to ./../../foo and this will grant access if ./ is permitted.

    • Update to 9.50~dfsg-5ubuntu4.12
    Published Updated
  3. CVE-2024-33869

    Medium · CVSS 5.3EPSS 0.45%Fix available

    CVE-2024-33869

    An issue was discovered in Artifex Ghostscript before 10.03.1. Path traversal and command execution can occur (via a crafted PostScript document) because of path reduction in base/gpmisc.c. For example, restrictions on use of %pipe% can be bypassed via the aa/../%pipe%command# output filename.

    • Update to 9.50~dfsg-5ubuntu4.12
    Published Updated
  4. CVE-2023-43115

    High · CVSS 8.8EPSS 5.96%Fix available

    CVE-2023-43115

    In Artifex Ghostscript through 10.01.2, gdevijs.c in GhostPDL can lead to remote code execution via crafted PostScript documents because they can switch to the IJS device, or change the IjsServer parameter, after SAFER has been activated. NOTE: it is a documented risk that the IJS server can be specified on a gs command line (the IJS device inherently must execute a command to start the IJS server).

    • Update to 9.50~dfsg-5ubuntu4.11
    Published Updated
  5. CVE-2023-38559

    Medium · CVSS 5.5EPSS 0.43%Fix available

    Ghostscript: out-of-bound read in base/gdevdevn.c:1973 in devn_pcx_write_rle could result in dos

    A buffer overflow flaw was found in base/gdevdevn.c:1973 in devn_pcx_write_rle() in ghostscript. This issue may allow a local attacker to cause a denial of service via outputting a crafted PDF file for a DEVN device with gs.

    • Update to 9.50~dfsg-5ubuntu4.9
    Published Updated
  6. CVE-2023-28879

    Critical · CVSS 9.8EPSS 6.34%Fix available

    CVE-2023-28879

    In Artifex Ghostscript through 10.01.0, there is a buffer overflow leading to potential corruption of data internal to the PostScript interpreter, in base/sbcp.c. This affects BCPEncode, BCPDecode, TBCPEncode, and TBCPDecode. If the write buffer is filled to one byte less than full, and one then tries to write an escaped character, two bytes are written.

    • Update to 9.50~dfsg-5ubuntu4.7
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →