p PatchFirst

CVE-2023-44446

CVE-2023-44446 · GStreamer MXF File Parsing Use-After-Free Remote Code Execution Vulnerability

This page contains facts from public vulnerability sources. Check the original advisory before updating.

GStreamer MXF File Parsing Use-After-Free Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of GStreamer. Interaction with this library is required to exploit this vulnerability but attack vectors may vary depending on the implementation. The specific flaw exists within the parsing of MXF video files. The issue results from the lack of validating the existence of an object prior to performing operations on the object. An attacker can leverage this vulnerability to execute code in the context of the current process. Was ZDI-CAN-22299.

CVSS 8.8 · High · EPSS 2.0% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • gstreamer

    Versions
    • 64a58c37acc564285a125f99570787fb678446c9: Affected

    No fix published

  • gst-plugins-bad1.0 Debian:12

    Versions
    • 1.22.0-4
    • 1.22.0-4+deb12u1
    • 1.22.0-4+deb12u2
    Affected ranges
    • ECOSYSTEM: < 1.22.0-4+deb12u3

    Update to 1.22.0-4+deb12u3

  • gst-plugins-bad1.0 Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.22.7-1

    Update to 1.22.7-1

  • gst-plugins-bad1.0 Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.22.7-1

    Update to 1.22.7-1

  • gst-plugins-bad0.10 Ubuntu:Pro:14.04:LTS

    Versions
    • 0.10.23-7ubuntu2
    • 0.10.23-7.2ubuntu1
    • 0.10.23-7.2ubuntu1.1
    • 0.10.23-7.2ubuntu1.2
    • 0.10.23-7.2ubuntu1.3
    • 0.10.23-7.2ubuntu1.3+esm1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • gst-plugins-bad1.0 Ubuntu:Pro:14.04:LTS

    Versions
    • 1.2.0-3ubuntu5
    • 1.2.1-1ubuntu1
    • 1.2.1-1ubuntu2
    • 1.2.2-1ubuntu1
    • 1.2.2-1ubuntu2
    • 1.2.2-1ubuntu4
    • 1.2.3-1ubuntu1
    • 1.2.3-1ubuntu2
    • 1.2.4-1~ubuntu1
    • 1.2.4-1~ubuntu1.1
    • 1.2.4-1~ubuntu1.1+esm1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • gst-plugins-bad1.0 Ubuntu:Pro:16.04:LTS

    Versions
    • 1.6.0-1ubuntu1
    • 1.6.1-1ubuntu1
    • 1.6.2-1ubuntu1
    • 1.7.1-1ubuntu1
    • 1.7.1-1ubuntu3
    • 1.7.1-1ubuntu4
    • 1.7.2-1ubuntu1
    • 1.7.90-1ubuntu2
    • 1.7.91-1ubuntu1
    • 1.8.0-1ubuntu1
    • 1.8.1-1ubuntu0.1
    • 1.8.2-1ubuntu0.1
    • 1.8.2-1ubuntu0.2
    • 1.8.3-1ubuntu0.2
    Affected ranges
    • ECOSYSTEM: < 1.8.3-1ubuntu0.2+esm1

    Update to 1.8.3-1ubuntu0.2+esm1

  • gst-plugins-bad1.0 Ubuntu:Pro:18.04:LTS

    Versions
    • 1.12.3-1ubuntu1
    • 1.12.3-1ubuntu2
    • 1.12.3-2ubuntu1
    • 1.12.4-2ubuntu1
    • 1.12.4-2ubuntu2
    • 1.13.1-1ubuntu1
    • 1.13.91-1ubuntu1
    • 1.14.0-1ubuntu1
    • 1.14.1-1ubuntu1~ubuntu18.04.1
    • 1.14.4-1ubuntu1~ubuntu18.04.1
    • 1.14.5-0ubuntu1~18.04.1
    Affected ranges
    • ECOSYSTEM: < 1.14.5-0ubuntu1~18.04.1+esm1

    Update to 1.14.5-0ubuntu1~18.04.1+esm1

  • gst-plugins-bad1.0 Ubuntu:20.04:LTS

    Versions
    • 1.16.1-1ubuntu1
    • 1.16.1-1ubuntu3
    • 1.16.1-1ubuntu4
    • 1.16.1-1ubuntu5
    • 1.16.1-1ubuntu6
    • 1.16.1-1ubuntu8
    • 1.16.2-1ubuntu1
    • 1.16.2-1ubuntu2
    • 1.16.2-2ubuntu1
    • 1.16.2-2.1ubuntu1
    • 1.16.3-0ubuntu1
    Affected ranges
    • ECOSYSTEM: < 1.16.3-0ubuntu1.1

    Update to 1.16.3-0ubuntu1.1

  • gst-plugins-bad1.0 Ubuntu:22.04:LTS

    Versions
    • 1.18.5-1ubuntu1
    • 1.18.5-1ubuntu3
    • 1.20.0-2ubuntu2
    • 1.20.1-1ubuntu2
    • 1.20.3-0ubuntu1
    Affected ranges
    • ECOSYSTEM: < 1.20.3-0ubuntu1.1

    Update to 1.20.3-0ubuntu1.1

Original sources

Check your server →