p PatchFirst

CVE-2023-45133

CVE-2023-45133 · Babel vulnerable to arbitrary code execution when compiling specifically crafted malicious code

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Babel is a compiler for writingJavaScript. In `@babel/traverse` prior to versions 7.23.2 and 8.0.0-alpha.4 and all versions of `babel-traverse`, using Babel to compile code that was specifically crafted by an attacker can lead to arbitrary code execution during compilation, when using plugins that rely on the `path.evaluate()`or `path.evaluateTruthy()` internal Babel methods. Known affected plugins are `@babel/plugin-transform-runtime`; `@babel/preset-env` when using its `useBuiltIns` option; and any "polyfill provider" plugin that depends on `@babel/helper-define-polyfill-provider`, such as `babel-plugin-polyfill-corejs3`, `babel-plugin-polyfill-corejs2`, `babel-plugin-polyfill-es-shims`, `babel-plugin-polyfill-regenerator`. No other plugins under the `@babel/` namespace are impacted, but third-party plugins might be. Users that only compile trusted code are not impacted. The vulnerability has been fixed in `@babel/[email protected]` and `@babel/[email protected]`. Those who cannot upgrade `@babel/traverse` and are using one of the affected packages mentioned above should upgrade them to their latest version to avoid triggering the vulnerable code path in affected `@babel/traverse` versions: `@babel/plugin-transform-runtime` v7.23.2, `@babel/preset-env` v7.23.2, `@babel/helper-define-polyfill-provider` v0.4.3, `babel-plugin-polyfill-corejs2` v0.4.6, `babel-plugin-polyfill-corejs3` v0.8.5, `babel-plugin-polyfill-es-shims` v0.10.0, `babel-plugin-polyfill-regenerator` v0.5.3.

CVSS 9.4 · Critical · EPSS 0.5% · Fix available

Published
Updated

Stack: system · node

Affected products and versions

  • babel

    Versions
    • < 7.23.2: Affected
    • >= 8.0.0-alpha.0, < 8.0.0-alpha.4: Affected

    No fix published

  • node-babel7 Debian:12

    Versions
    • 7.20.15+ds1+~cs214.269.168-3
    Affected ranges
    • ECOSYSTEM: < 7.20.15+ds1+~cs214.269.168-3+deb12u1

    Update to 7.20.15+ds1+~cs214.269.168-3+deb12u1

  • node-babel7 Debian:13

    Affected ranges
    • ECOSYSTEM: < 7.20.15+ds1+~cs214.269.168-5

    Update to 7.20.15+ds1+~cs214.269.168-5

  • node-babel7 Debian:14

    Affected ranges
    • ECOSYSTEM: < 7.20.15+ds1+~cs214.269.168-5

    Update to 7.20.15+ds1+~cs214.269.168-5

  • @babel/traverse npm

    Affected ranges
    • SEMVER: < 7.23.2

    Update to 7.23.2

  • @babel/traverse npm

    Affected ranges
    • SEMVER: ≥ 8.0.0-alpha.0, < 8.0.0-alpha.4

    Update to 8.0.0-alpha.4

  • babel-traverse npm

    Affected ranges
    • SEMVER: (−∞, +∞)

    No fix published

  • node-babel Ubuntu:18.04:LTS

    Versions
    • 6.26.0+dfsg-3build5
    • 6.26.0+dfsg-3build6
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • node-babel Ubuntu:20.04:LTS

    Versions
    • 6.26.0+dfsg-3build6
    • 6.26.0+repack-2
    • 6.26.0+repack-3
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • node-babel7 Ubuntu:22.04:LTS

    Versions
    • 7.12.12+~cs150.141.84-6
    • 7.12.12+~cs150.141.84-7
    • 7.12.12+~cs150.141.84-8
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • node-babel7 Ubuntu:24.04:LTS

    Versions
    • 7.20.15+ds1+~cs214.269.168-4
    • 7.20.15+ds1+~cs214.269.168-5
    • 7.20.15+ds1+~cs214.269.168-6
    • 7.20.15+ds1+~cs214.269.168-6build1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →