p PatchFirst

PatchFirst · Latest vulnerabilities

node-babel7 vulnerabilities

Vulnerabilities published for node-babel7 in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 3

  1. CVE-2026-49356

    Low · CVSS 3.2EPSS 0.15%Fix available

    Babel: Arbitrary File Read via sourceMappingURL Comment in @babel/core

    Babel is a compiler for writing next generation JavaScript. Prior to 8.0.0-rc.6 and 7.29.6, @babel/core affected by an arbitrary file read via a sourceMappingURL comment. Using @babel/core to compile maliciously crafted code can allow an attacker to read any source map from the system that is running Babel, if the attacker controls the input source code, can read the output source code, and knows the path of the source map file that they want to read. This vulnerability is fixed in 8.0.0-rc.6 and 7.29.6.

    • Update to 8.0.4+ds1+~cs177.303.116-2
    Published Updated
  2. CVE-2026-44728

    High · CVSS 8.2EPSS 0.12%Fix available

    Improper Control of Generation of Code when compiling specifically crafted malicious code with @babel/plugin-transform-modules-systemjs

    Babel is a compiler for writing next generation JavaScript. From 7.12.0 to before 7.29.4 and 8.0.0-alpha.13, using Babel to compile code that was specifically crafted by an attacker can cause Babel to generate output code that executes arbitrary code. This vulnerability is fixed in 7.29.4 and 8.0.0-alpha.13.

    • Update to 8.0.4+ds1+~cs177.303.116-2
    Published Updated
  3. CVE-2023-45133

    Critical · CVSS 9.4EPSS 0.53%Fix available

    Babel vulnerable to arbitrary code execution when compiling specifically crafted malicious code

    Babel is a compiler for writingJavaScript. In `@babel/traverse` prior to versions 7.23.2 and 8.0.0-alpha.4 and all versions of `babel-traverse`, using Babel to compile code that was specifically crafted by an attacker can lead to arbitrary code execution during compilation, when using plugins that rely on the `path.evaluate()`or `path.evaluateTruthy()` internal Babel methods. Known affected plugins are `@babel/plugin-transform-runtime`; `@babel/preset-env` when using its `useBuiltIns` option; and any "polyfill provider" plugin that depends on `@babel/helper-define-polyfill-provider`, such as `babel-plugin-polyfill-corejs3`, `babel-plugin-poly

    • Update to 7.20.15+ds1+~cs214.269.168-5
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →