p PatchFirst

CVE-2023-7104

CVE-2023-7104 · SQLite SQLite3 make alltest sqlite3session.c sessionReadRecord heap-based overflow

This page contains facts from public vulnerability sources. Check the original advisory before updating.

A vulnerability was found in SQLite SQLite3 up to 3.43.0 and classified as critical. This issue affects the function sessionReadRecord of the file ext/session/sqlite3session.c of the component make alltest Handler. The manipulation leads to heap-based buffer overflow. It is recommended to apply a patch to fix this issue. The associated identifier of this vulnerability is VDB-248999.

CVSS 5.5 · Medium · EPSS 1.5% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • sqlite3

    Versions
    • 3.0: Affected
    • 3.1: Affected
    • 3.2: Affected
    • 3.3: Affected
    • 3.4: Affected
    • 3.5: Affected
    • 3.6: Affected
    • 3.7: Affected
    • 3.8: Affected
    • 3.9: Affected
    • 3.10: Affected
    • 3.11: Affected
    • 3.12: Affected
    • 3.13: Affected
    • 3.14: Affected
    • 3.15: Affected
    • 3.16: Affected
    • 3.17: Affected
    • 3.18: Affected
    • 3.19: Affected
    • 3.20: Affected
    • 3.21: Affected
    • 3.22: Affected
    • 3.23: Affected
    • 3.24: Affected
    • 3.25: Affected
    • 3.26: Affected
    • 3.27: Affected
    • 3.28: Affected
    • 3.29: Affected
    • 3.30: Affected
    • 3.31: Affected
    • 3.32: Affected
    • 3.33: Affected
    • 3.34: Affected
    • 3.35: Affected
    • 3.36: Affected
    • 3.37: Affected
    • 3.38: Affected
    • 3.39: Affected
    • 3.40: Affected
    • 3.41: Affected
    • 3.42: Affected
    • 3.43: Affected

    No fix published

  • sqlite3 Debian:12

    Versions
    • 3.40.1-2
    Affected ranges
    • ECOSYSTEM: < 3.40.1-2+deb12u1

    Update to 3.40.1-2+deb12u1

  • sqlite3 Debian:13

    Affected ranges
    • ECOSYSTEM: < 3.43.1-1

    Update to 3.43.1-1

  • sqlite3 Debian:14

    Affected ranges
    • ECOSYSTEM: < 3.43.1-1

    Update to 3.43.1-1

  • sqlite3 Ubuntu:Pro:18.04:LTS

    Versions
    • 3.19.3-3
    • 3.20.1-2
    • 3.21.0-1
    • 3.22.0-1
    • 3.22.0-1ubuntu0.1
    • 3.22.0-1ubuntu0.2
    • 3.22.0-1ubuntu0.3
    • 3.22.0-1ubuntu0.4
    • 3.22.0-1ubuntu0.5
    • 3.22.0-1ubuntu0.6
    • 3.22.0-1ubuntu0.7
    Affected ranges
    • ECOSYSTEM: < 3.22.0-1ubuntu0.7+esm1

    Update to 3.22.0-1ubuntu0.7+esm1

  • sqlite3 Ubuntu:20.04:LTS

    Versions
    • 3.29.0-2
    • 3.30.1-1
    • 3.30.1-1ubuntu1
    • 3.31.1-1ubuntu1
    • 3.31.1-3
    • 3.31.1-4
    • 3.31.1-4ubuntu0.1
    • 3.31.1-4ubuntu0.2
    • 3.31.1-4ubuntu0.3
    • 3.31.1-4ubuntu0.4
    • 3.31.1-4ubuntu0.5
    Affected ranges
    • ECOSYSTEM: < 3.31.1-4ubuntu0.6

    Update to 3.31.1-4ubuntu0.6

  • sqlite3 Ubuntu:22.04:LTS

    Versions
    • 3.35.5-1
    • 3.36.0-2
    • 3.37.2-2
    • 3.37.2-2ubuntu0.1
    Affected ranges
    • ECOSYSTEM: < 3.37.2-2ubuntu0.3

    Update to 3.37.2-2ubuntu0.3

Original sources

Check your server →