CVE-2024-0444
CVE-2024-0444 · GStreamer AV1 Video Parsing Stack-based Buffer Overflow Remote Code Execution Vulnerability
This page contains facts from public vulnerability sources. Check the original advisory before updating.
GStreamer AV1 Video Parsing Stack-based Buffer Overflow Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of GStreamer. Interaction with this library is required to exploit this vulnerability but attack vectors may vary depending on the implementation. The specific flaw exists within the parsing of tile list data within AV1-encoded video files. The issue results from the lack of proper validation of the length of user-supplied data prior to copying it to a fixed-length stack-based buffer. An attacker can leverage this vulnerability to execute code in the context of the current process. Was ZDI-CAN-22873.
CVSS 7.5 · High · EPSS 1.6% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
gstreamer
- Versions
- ea6d602ccacee5f4bdf45b9f58eb0dc5320f3c07: Affected
No fix published
gst-plugins-bad1.0 Debian:12
- Versions
- 1.22.0-4
- 1.22.0-4+deb12u1
- 1.22.0-4+deb12u2
- 1.22.0-4+deb12u3
- 1.22.0-4+deb12u4
- Affected ranges
- ECOSYSTEM: < 1.22.0-4+deb12u5
Update to 1.22.0-4+deb12u5
gst-plugins-bad1.0 Debian:13
- Affected ranges
- ECOSYSTEM: < 1.22.9-1
Update to 1.22.9-1
gst-plugins-bad1.0 Debian:14
- Affected ranges
- ECOSYSTEM: < 1.22.9-1
Update to 1.22.9-1
gst-plugins-bad1.0 Ubuntu:Pro:22.04:LTS
- Versions
- 1.18.5-1ubuntu1
- 1.18.5-1ubuntu3
- 1.20.0-2ubuntu2
- 1.20.1-1ubuntu2
- 1.20.3-0ubuntu1
- 1.20.3-0ubuntu1.1
- Affected ranges
- ECOSYSTEM: < 1.20.3-0ubuntu1.1+esm2
Update to 1.20.3-0ubuntu1.1+esm2