CVE-2024-21733
CVE-2024-21733 · Apache Tomcat: Leaking of unrelated request bodies in default error page
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Generation of Error Message Containing Sensitive Information vulnerability in Apache Tomcat.This issue affects Apache Tomcat: from 8.5.7 through 8.5.63, from 9.0.0-M11 through 9.0.43. Other, EOL versions may also be affected. Users are recommended to upgrade to version 8.5.64 onwards or 9.0.44 onwards, which contain a fix for the issue.
CVSS 5.3 · Medium · EPSS 14.3% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
apache tomcat
- Versions
- ≥ 8.5.7, ≤ 8.5.63: Affected (semver)
- ≥ 9.0.0-M11, ≤ 9.0.43: Affected (semver)
- ≥ 10.0.0-M1, ≤ 10.0.27: Unknown (semver)
No fix published
tomcat9 Debian:12
- Affected ranges
- ECOSYSTEM: < 9.0.53-1
Update to 9.0.53-1
tomcat9 Debian:13
- Affected ranges
- ECOSYSTEM: < 9.0.53-1
Update to 9.0.53-1
tomcat9 Debian:14
- Affected ranges
- ECOSYSTEM: < 9.0.53-1
Update to 9.0.53-1
tomcat6 Ubuntu:Pro:14.04:LTS
- Versions
- 6.0.37-1
- 6.0.39-1
- 6.0.39-1ubuntu0.1
- 6.0.39-1ubuntu0.1+esm1
- 6.0.39-1ubuntu0.1+esm2
- 6.0.39-1ubuntu0.1+esm3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
tomcat8 Ubuntu:Pro:18.04:LTS
- Versions
- 8.5.21-1ubuntu1
- 8.5.29-1
- 8.5.30-1
- 8.5.30-1ubuntu1
- 8.5.30-1ubuntu1.2
- 8.5.30-1ubuntu1.3
- 8.5.30-1ubuntu1.4
- 8.5.39-1ubuntu1~18.04.1
- 8.5.39-1ubuntu1~18.04.2
- 8.5.39-1ubuntu1~18.04.3
- 8.5.39-1ubuntu1~18.04.3+esm1
- 8.5.39-1ubuntu1~18.04.3+esm2
- 8.5.39-1ubuntu1~18.04.3+esm3
- 8.5.39-1ubuntu1~18.04.3+esm4
- Affected ranges
- ECOSYSTEM: < 8.5.39-1ubuntu1~18.04.3+esm5
Update to 8.5.39-1ubuntu1~18.04.3+esm5
tomcat9 Ubuntu:Pro:18.04:LTS
- Versions
- 9.0.16-3~18.04.1
- 9.0.16-3ubuntu0.18.04.1
- 9.0.16-3ubuntu0.18.04.2
- 9.0.16-3ubuntu0.18.04.2+esm1
- 9.0.16-3ubuntu0.18.04.2+esm2
- 9.0.16-3ubuntu0.18.04.2+esm3
- 9.0.16-3ubuntu0.18.04.2+esm4
- 9.0.16-3ubuntu0.18.04.2+esm5
- 9.0.16-3ubuntu0.18.04.2+esm6
- Affected ranges
- ECOSYSTEM: < 9.0.16-3ubuntu0.18.04.2+esm7
Update to 9.0.16-3ubuntu0.18.04.2+esm7
tomcat9 Ubuntu:Pro:20.04:LTS
- Versions
- 9.0.24-1
- 9.0.27-1
- 9.0.31-1
- 9.0.31-1ubuntu0.1
- 9.0.31-1ubuntu0.2
- 9.0.31-1ubuntu0.3
- 9.0.31-1ubuntu0.4
- 9.0.31-1ubuntu0.5
- 9.0.31-1ubuntu0.6
- 9.0.31-1ubuntu0.7
- 9.0.31-1ubuntu0.8
- 9.0.31-1ubuntu0.9
- 9.0.31-1ubuntu0.9+esm1
- Affected ranges
- ECOSYSTEM: < 9.0.31-1ubuntu0.9+esm2
Update to 9.0.31-1ubuntu0.9+esm2
Original sources
- https://lists.apache.org/thread/h9bjqdd0odj6lhs2o96qgowcc6hb0cfz
- http://www.openwall.com/lists/oss-security/2024/01/19/2
- http://packetstormsecurity.com/files/176951/Apache-Tomcat-8.5.63-9.0.43-HTTP-Response-Smuggling.html
- https://security.netapp.com/advisory/ntap-20240216-0005/
- https://lists.debian.org/debian-lts-announce/2025/01/msg00009.html
- https://nvd.nist.gov/vuln/detail/CVE-2024-21733