CVE-2024-2199
CVE-2024-2199 · 389-ds-base: malformed userpassword may cause crash at do_modify in slapd/modify.c
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A denial of service vulnerability was found in 389-ds-base ldap server. This issue may allow an authenticated user to cause a server crash while modifying `userPassword` using malformed input.
CVSS 5.7 · Medium · EPSS 0.6% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
red hat directory server 11.5 e4s for rhel 8
- Versions
- ≥ 8060020250210084424.0ca98e7e: Not affected (rpm)
No fix published
red hat directory server 11.8 for rhel 8
- Versions
- ≥ 8090020240606122459.91529cd0: Not affected (rpm)
No fix published
red hat directory server 11.9 for rhel 8
- Versions
- ≥ 8100020240604161237.37ed7c03: Not affected (rpm)
No fix published
red hat directory server 12.4 for rhel 9
- Versions
- ≥ 9040020240604143706.1674d574: Not affected (rpm)
No fix published
red hat enterprise linux 7
- Versions
- ≥ 0:1.3.11.1-5.el7_9: Not affected (rpm)
No fix published
red hat enterprise linux 8
- Versions
- ≥ 8100020240613122040.25e700aa: Not affected (rpm)
No fix published
red hat enterprise linux 8.8 extended update support
- Versions
- ≥ 8080020240807050952.6dbb3803: Not affected (rpm)
No fix published
red hat enterprise linux 9
- Versions
- ≥ 0:2.4.5-8.el9_4: Not affected (rpm)
No fix published
red hat enterprise linux 9.2 extended update support
- Versions
- ≥ 0:2.2.4-9.el9_2: Not affected (rpm)
No fix published
red hat enterprise linux 6
No fix published
389-ds-base Debian:12
- Versions
- 2.3.1+dfsg1-1
- Affected ranges
- ECOSYSTEM: < 2.3.1+dfsg1-1+deb12u1
Update to 2.3.1+dfsg1-1+deb12u1
389-ds-base Debian:13
- Affected ranges
- ECOSYSTEM: < 3.1.1+dfsg1-1
Update to 3.1.1+dfsg1-1
389-ds-base Ubuntu:Pro:16.04:LTS
- Versions
- 1.3.3.12-1build1
- 1.3.3.13-1
- 1.3.4.5-2
- 1.3.4.8-1
- 1.3.4.8-3
- 1.3.4.8-3ubuntu1
- 1.3.4.8-4
- 1.3.4.9-1
- 1.3.4.9-1ubuntu0.1~esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
389-ds-base Ubuntu:Pro:18.04:LTS
- Versions
- 1.3.7.5-1
- 1.3.7.5-1build1
- 1.3.7.5-1build2
- 1.3.7.9-1
- 1.3.7.10-1
- 1.3.7.10-1ubuntu1
- 1.3.7.10-1ubuntu1+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
389-ds-base Ubuntu:Pro:20.04:LTS
- Versions
- 1.4.1.6-4
- 1.4.1.6-4build1
- 1.4.2.4-1
- 1.4.2.4-1build1
- 1.4.3.2-1
- 1.4.3.2-1build1
- 1.4.3.6-2
- 1.4.3.6-2ubuntu0.1~esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
389-ds-base Ubuntu:22.04:LTS
- Versions
- 1.4.4.11-2build1
- 1.4.4.11-2build2
- 1.4.4.17-1
- 2.0.11-2
- 2.0.14-1
- 2.0.15-1
- 2.0.15-1ubuntu2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
389-ds-base Ubuntu:24.04:LTS
- Versions
- 2.3.4+dfsg1-1
- 2.4.4+dfsg1-1ubuntu1
- 2.4.4+dfsg1-1ubuntu4
- 2.4.4+dfsg1-3
- 2.4.5+dfsg1-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
389-ds-base Ubuntu:25.10
- Versions
- 3.1.2+dfsg1-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
389-ds-base Ubuntu:26.10
- Versions
- 3.1.2+vendor1-2
- 3.1.2+vendor1-2build1
- 3.3.1-3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
389-ds-base Ubuntu:26.04:LTS
- Versions
- 3.1.2+dfsg1-1
- 3.1.2+vendor1-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://access.redhat.com/errata/RHSA-2024:3591
- https://access.redhat.com/errata/RHSA-2024:3837
- https://access.redhat.com/errata/RHSA-2024:4092
- https://access.redhat.com/errata/RHSA-2024:4209
- https://access.redhat.com/errata/RHSA-2024:4210
- https://access.redhat.com/errata/RHSA-2024:4235
- https://access.redhat.com/errata/RHSA-2024:4633
- https://access.redhat.com/errata/RHSA-2024:5690
- https://access.redhat.com/errata/RHSA-2025:1632
- https://access.redhat.com/security/cve/CVE-2024-2199
- https://bugzilla.redhat.com/show_bug.cgi?id=2267976
- https://www.port389.org/docs/389ds/releases/release-3-1-1.html
- https://lists.debian.org/debian-lts-announce/2025/01/msg00015.html
- https://nvd.nist.gov/vuln/detail/CVE-2024-2199