CVE-2024-25062
CVE-2024-25062
This page contains facts from public vulnerability sources. Check the original advisory before updating.
An issue was discovered in libxml2 before 2.11.7 and 2.12.x before 2.12.5. When using the XML Reader interface with DTD validation and XInclude expansion enabled, processing crafted XML documents can lead to an xmlValidatePopElement use-after-free.
CVSS 7.5 · High · EPSS 1.3% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
libxml2 Debian:12
- Versions
- 2.9.14+dfsg-1.2
- 2.9.14+dfsg-1.3~deb12u1
- Affected ranges
- ECOSYSTEM: < 2.9.14+dfsg-1.3~deb12u2
Update to 2.9.14+dfsg-1.3~deb12u2
libxml2 Debian:13
- Affected ranges
- ECOSYSTEM: < 2.12.7+dfsg+really2.9.14-1
Update to 2.12.7+dfsg+really2.9.14-1
libxml2 Debian:14
- Affected ranges
- ECOSYSTEM: < 2.12.7+dfsg+really2.9.14-1
Update to 2.12.7+dfsg+really2.9.14-1
libxml2 Ubuntu:Pro:14.04:LTS
- Versions
- 2.9.1+dfsg1-3ubuntu2
- 2.9.1+dfsg1-3ubuntu3
- 2.9.1+dfsg1-3ubuntu4
- 2.9.1+dfsg1-3ubuntu4.1
- 2.9.1+dfsg1-3ubuntu4.2
- 2.9.1+dfsg1-3ubuntu4.3
- 2.9.1+dfsg1-3ubuntu4.4
- 2.9.1+dfsg1-3ubuntu4.5
- 2.9.1+dfsg1-3ubuntu4.6
- 2.9.1+dfsg1-3ubuntu4.7
- 2.9.1+dfsg1-3ubuntu4.8
- 2.9.1+dfsg1-3ubuntu4.9
- 2.9.1+dfsg1-3ubuntu4.10
- 2.9.1+dfsg1-3ubuntu4.11
- 2.9.1+dfsg1-3ubuntu4.12
- 2.9.1+dfsg1-3ubuntu4.13
- 2.9.1+dfsg1-3ubuntu4.13+esm1
- 2.9.1+dfsg1-3ubuntu4.13+esm2
- 2.9.1+dfsg1-3ubuntu4.13+esm3
- 2.9.1+dfsg1-3ubuntu4.13+esm4
- 2.9.1+dfsg1-3ubuntu4.13+esm5
- Affected ranges
- ECOSYSTEM: < 2.9.1+dfsg1-3ubuntu4.13+esm6
Update to 2.9.1+dfsg1-3ubuntu4.13+esm6
libxml2 Ubuntu:Pro:16.04:LTS
- Versions
- 2.9.2+zdfsg1-4
- 2.9.2+zdfsg1-4ubuntu1
- 2.9.2+zdfsg1-4ubuntu2
- 2.9.2+zdfsg1-4ubuntu3
- 2.9.3+dfsg1-1
- 2.9.3+dfsg1-1ubuntu0.1
- 2.9.3+dfsg1-1ubuntu0.2
- 2.9.3+dfsg1-1ubuntu0.3
- 2.9.3+dfsg1-1ubuntu0.4
- 2.9.3+dfsg1-1ubuntu0.5
- 2.9.3+dfsg1-1ubuntu0.6
- 2.9.3+dfsg1-1ubuntu0.7
- 2.9.3+dfsg1-1ubuntu0.7+esm1
- 2.9.3+dfsg1-1ubuntu0.7+esm2
- 2.9.3+dfsg1-1ubuntu0.7+esm3
- 2.9.3+dfsg1-1ubuntu0.7+esm4
- 2.9.3+dfsg1-1ubuntu0.7+esm5
- Affected ranges
- ECOSYSTEM: < 2.9.3+dfsg1-1ubuntu0.7+esm6
Update to 2.9.3+dfsg1-1ubuntu0.7+esm6
libxml2 Ubuntu:Pro:18.04:LTS
- Versions
- 2.9.4+dfsg1-4ubuntu1
- 2.9.4+dfsg1-5ubuntu1
- 2.9.4+dfsg1-5ubuntu2
- 2.9.4+dfsg1-5.1ubuntu1
- 2.9.4+dfsg1-5.2ubuntu1
- 2.9.4+dfsg1-6.1ubuntu1
- 2.9.4+dfsg1-6.1ubuntu1.2
- 2.9.4+dfsg1-6.1ubuntu1.3
- 2.9.4+dfsg1-6.1ubuntu1.4
- 2.9.4+dfsg1-6.1ubuntu1.5
- 2.9.4+dfsg1-6.1ubuntu1.6
- 2.9.4+dfsg1-6.1ubuntu1.7
- 2.9.4+dfsg1-6.1ubuntu1.8
- 2.9.4+dfsg1-6.1ubuntu1.9
- Affected ranges
- ECOSYSTEM: < 2.9.4+dfsg1-6.1ubuntu1.9+esm1
Update to 2.9.4+dfsg1-6.1ubuntu1.9+esm1
libxml2 Ubuntu:20.04:LTS
- Versions
- 2.9.4+dfsg1-7ubuntu3
- 2.9.4+dfsg1-7ubuntu5
- 2.9.4+dfsg1-8ubuntu1
- 2.9.4+dfsg1-8ubuntu2
- 2.9.4+dfsg1-8ubuntu3
- 2.9.10+dfsg-1ubuntu3
- 2.9.10+dfsg-4build1
- 2.9.10+dfsg-5
- 2.9.10+dfsg-5ubuntu0.20.04.1
- 2.9.10+dfsg-5ubuntu0.20.04.2
- 2.9.10+dfsg-5ubuntu0.20.04.3
- 2.9.10+dfsg-5ubuntu0.20.04.4
- 2.9.10+dfsg-5ubuntu0.20.04.5
- 2.9.10+dfsg-5ubuntu0.20.04.6
- Affected ranges
- ECOSYSTEM: < 2.9.10+dfsg-5ubuntu0.20.04.7
Update to 2.9.10+dfsg-5ubuntu0.20.04.7
libxml2 Ubuntu:22.04:LTS
- Versions
- 2.9.12+dfsg-4
- 2.9.12+dfsg-5
- 2.9.12+dfsg-6
- 2.9.13+dfsg-1
- 2.9.13+dfsg-1build1
- 2.9.13+dfsg-1ubuntu0.1
- 2.9.13+dfsg-1ubuntu0.2
- 2.9.13+dfsg-1ubuntu0.3
- Affected ranges
- ECOSYSTEM: < 2.9.13+dfsg-1ubuntu0.4
Update to 2.9.13+dfsg-1ubuntu0.4
Original sources
- https://gitlab.gnome.org/GNOME/libxml2/-/tags
- https://gitlab.gnome.org/GNOME/libxml2/-/issues/604
- https://lists.debian.org/debian-lts-announce/2025/02/msg00028.html
- https://security.netapp.com/advisory/ntap-20241018-0009/
- https://cert-portal.siemens.com/productcert/html/ssa-794697.html
- https://cert-portal.siemens.com/productcert/html/ssa-784301.html
- https://nvd.nist.gov/vuln/detail/CVE-2024-25062