CVE-2024-25641
CVE-2024-25641 · Cacti RCE vulnerability when importing packages
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Cacti provides an operational monitoring and fault management framework. Prior to version 1.2.27, an arbitrary file write vulnerability, exploitable through the "Package Import" feature, allows authenticated users having the "Import Templates" permission to execute arbitrary PHP code on the web server. The vulnerability is located within the `import_package()` function defined into the `/lib/import.php` script. The function blindly trusts the filename and file content provided within the XML data, and writes such files into the Cacti base path (or even outside, since path traversal sequences are not filtered). This can be exploited to write or overwrite arbitrary files on the web server, leading to execution of arbitrary PHP code or other security impacts. Version 1.2.27 contains a patch for this issue.
CVSS 9.1 · Critical · EPSS 86.3% · Public exploit · Fix available
- Published
- Updated
Stack: system
Affected products and versions
cacti
- Versions
- < 1.2.27: Affected
No fix published
cacti Debian:12
- Versions
- 1.2.24+ds1-1
- 1.2.24+ds1-1+deb12u1
- 1.2.24+ds1-1+deb12u2
- Affected ranges
- ECOSYSTEM: < 1.2.24+ds1-1+deb12u3
Update to 1.2.24+ds1-1+deb12u3
cacti Debian:13
- Affected ranges
- ECOSYSTEM: < 1.2.27+ds1-1
Update to 1.2.27+ds1-1
cacti Debian:14
- Affected ranges
- ECOSYSTEM: < 1.2.27+ds1-1
Update to 1.2.27+ds1-1
cacti Ubuntu:Pro:18.04:LTS
- Versions
- 1.1.18+ds1-1
- 1.1.27+ds1-2
- 1.1.27+ds1-3
- 1.1.28+ds1-2
- 1.1.35+ds1-1
- 1.1.36+ds1-1
- 1.1.38+ds1-1
- 1.1.38+ds1-1ubuntu0.1~esm1
- Affected ranges
- ECOSYSTEM: < 1.1.38+ds1-1ubuntu0.1~esm3
Update to 1.1.38+ds1-1ubuntu0.1~esm3
cacti Ubuntu:20.04:LTS
- Versions
- 1.2.4+ds1-2ubuntu3
- 1.2.9+ds1-1ubuntu1
- 1.2.9+ds1-1ubuntu2
- 1.2.10+ds1-1ubuntu1
- Affected ranges
- ECOSYSTEM: < 1.2.10+ds1-1ubuntu1.1
Update to 1.2.10+ds1-1ubuntu1.1
cacti Ubuntu:22.04:LTS
- Versions
- 1.2.16+ds1-2ubuntu1
- 1.2.19+ds1-2ubuntu1
- Affected ranges
- ECOSYSTEM: < 1.2.19+ds1-2ubuntu1.1
Update to 1.2.19+ds1-2ubuntu1.1
cacti Ubuntu:24.04:LTS
- Versions
- 1.2.25+ds1-2
- 1.2.26+ds1-1
- Affected ranges
- ECOSYSTEM: < 1.2.26+ds1-1ubuntu0.1
Update to 1.2.26+ds1-1ubuntu0.1
Original sources
- https://github.com/Cacti/cacti/security/advisories/GHSA-7cmj-g5qc-pj88
- https://github.com/Cacti/cacti/commit/eff35b0ff26cc27c82d7880469ed6d5e3bef6210
- https://lists.fedoraproject.org/archives/list/[email protected]/message/RBEOAFKRARQHTDIYSL723XAFJ2Q6624X/
- http://seclists.org/fulldisclosure/2024/May/6
- https://lists.debian.org/debian-lts-announce/2024/09/msg00027.html
- https://nvd.nist.gov/vuln/detail/CVE-2024-25641