p PatchFirst

PatchFirst · Latest vulnerabilities

cacti vulnerabilities

Vulnerabilities published for cacti in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 8

  1. CVE-2024-34340

    Critical · CVSS 9.1EPSS 1.12%Fix available

    Authentication Bypass when using using older password hashes

    Cacti provides an operational monitoring and fault management framework. Prior to version 1.2.27, Cacti calls `compat_password_hash` when users set their password. `compat_password_hash` use `password_hash` if there is it, else use `md5`. When verifying password, it calls `compat_password_verify`. In `compat_password_verify`, `password_verify` is called if there is it, else use `md5`. `password_verify` and `password_hash` are supported on PHP < 5.5.0, following PHP manual. The vulnerability is in `compat_password_verify`. Md5-hashed user input is compared with correct password in database by `$md5 == $hash`. It is a loose comparison, not `===

    • Update to 1.2.10+ds1-1ubuntu1.1
    Published Updated
  2. CVE-2024-31460

    Medium · CVSS 6.5EPSS 1.79%Fix available

    Cacti SQL Injection vulnerability in lib/api_automation.php caused by reading dirty data stored in database

    Cacti provides an operational monitoring and fault management framework. Prior to version 1.2.27, some of the data stored in `automation_tree_rules.php` is not thoroughly checked and is used to concatenate the SQL statement in `create_all_header_nodes()` function from `lib/api_automation.php` , finally resulting in SQL injection. Using SQL based secondary injection technology, attackers can modify the contents of the Cacti database, and based on the modified content, it may be possible to achieve further impact, such as arbitrary file reading, and even remote code execution through arbitrary file writing. Version 1.2.27 contains a patch for

    • Update to 1.2.10+ds1-1ubuntu1.1
    Published Updated
  3. CVE-2024-31459

    High · CVSS 8.1EPSS 2.68%Fix available

    Cacti RCE vulnerability by file include in lib/plugin.php

    Cacti provides an operational monitoring and fault management framework. Prior to version 1.2.27, there is a file inclusion issue in the `lib/plugin.php` file. Combined with SQL injection vulnerabilities, remote code execution can be implemented. There is a file inclusion issue with the `api_plugin_hook()` function in the `lib/plugin.php` file, which reads the plugin_hooks and plugin_config tables in database. The read data is directly used to concatenate the file path which is used for file inclusion. Version 1.2.27 contains a patch for the issue.

    • Update to 1.2.10+ds1-1ubuntu1.1
    Published Updated
  4. CVE-2024-31458

    Medium · CVSS 4.6EPSS 12.6%Fix available

    Cacti SQL Injection vulnerability in lib/html_form_templates.php by reading dirty data stored in database

    Cacti provides an operational monitoring and fault management framework. Prior to version 1.2.27, some of the data stored in `form_save()` function in `graph_template_inputs.php` is not thoroughly checked and is used to concatenate the SQL statement in `draw_nontemplated_fields_graph_item()` function from `lib/html_form_templates.php` , finally resulting in SQL injection. Version 1.2.27 contains a patch for the issue.

    • Update to 1.2.10+ds1-1ubuntu1.1
    Published Updated
  5. CVE-2024-31445

    High · CVSS 8.8EPSS 26.15%Fix available

    SQL Injection vulnerability in automation_get_new_graphs_sql

    Cacti provides an operational monitoring and fault management framework. Prior to version 1.2.27, a SQL injection vulnerability in `automation_get_new_graphs_sql` function of `api_automation.php` allows authenticated users to exploit these SQL injection vulnerabilities to perform privilege escalation and remote code execution. In `api_automation.php` line 856, the `get_request_var('filter')` is being concatenated into the SQL statement without any sanitization. In `api_automation.php` line 717, The filter of `'filter'` is `FILTER_DEFAULT`, which means there is no filter for it. Version 1.2.27 contains a patch for the issue.

    • Update to 1.2.10+ds1-1ubuntu1.1
    Published Updated
  6. CVE-2024-31444

    Medium · CVSS 4.6EPSS 14.66%Fix available

    Cacti XSS vulnerability in lib/html.php by reading dirty data stored in database

    Cacti provides an operational monitoring and fault management framework. Prior to version 1.2.27, some of the data stored in `automation_tree_rules_form_save()` function in `automation_tree_rules.php` is not thoroughly checked and is used to concatenate the HTML statement in `form_confirm()` function from `lib/html.php` , finally resulting in cross-site scripting. Version 1.2.27 contains a patch for the issue.

    • Update to 1.2.10+ds1-1ubuntu1.1
    Published Updated
  7. CVE-2024-31443

    Medium · CVSS 5.7EPSS 0.84%Fix available

    Cacti XSS vulnerability in lib/html_tree.php by reading dirty data stored in database

    Cacti provides an operational monitoring and fault management framework. Prior to 1.2.27, some of the data stored in `form_save()` function in `data_queries.php` is not thoroughly checked and is used to concatenate the HTML statement in `grow_right_pane_tree()` function from `lib/html.php` , finally resulting in cross-site scripting. Version 1.2.27 contains a patch for the issue.

    • Update to 1.2.10+ds1-1ubuntu1.1
    Published Updated
  8. CVE-2024-25641

    Critical · CVSS 9.1EPSS 86.3%Public exploitFix available

    Cacti RCE vulnerability when importing packages

    Cacti provides an operational monitoring and fault management framework. Prior to version 1.2.27, an arbitrary file write vulnerability, exploitable through the "Package Import" feature, allows authenticated users having the "Import Templates" permission to execute arbitrary PHP code on the web server. The vulnerability is located within the `import_package()` function defined into the `/lib/import.php` script. The function blindly trusts the filename and file content provided within the XML data, and writes such files into the Cacti base path (or even outside, since path traversal sequences are not filtered). This can be exploited to write o

    • Update to 1.2.10+ds1-1ubuntu1.1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →