CVE-2024-29510
CVE-2024-29510
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Artifex Ghostscript before 10.03.1 allows memory corruption, and SAFER sandbox bypass, via format string injection with a uniprint device.
CVSS 6.3 · Medium · EPSS 28.0% · Public exploit · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
ghostscript Debian:12
- Versions
- 10.0.0~dfsg-11
- 10.0.0~dfsg-11+deb12u1
- 10.0.0~dfsg-11+deb12u2
- 10.0.0~dfsg-11+deb12u3
- Affected ranges
- ECOSYSTEM: < 10.0.0~dfsg-11+deb12u4
Update to 10.0.0~dfsg-11+deb12u4
ghostscript Debian:13
- Affected ranges
- ECOSYSTEM: < 10.03.1~dfsg~git20240518-1
Update to 10.03.1~dfsg~git20240518-1
ghostscript Debian:14
- Affected ranges
- ECOSYSTEM: < 10.03.1~dfsg~git20240518-1
Update to 10.03.1~dfsg~git20240518-1
ghostscript Ubuntu:20.04:LTS
- Versions
- 9.27~dfsg+0-0ubuntu3
- 9.27~dfsg+0-0ubuntu4
- 9.50~dfsg-5ubuntu1
- 9.50~dfsg-5ubuntu2
- 9.50~dfsg-5ubuntu3
- 9.50~dfsg-5ubuntu4
- 9.50~dfsg-5ubuntu4.1
- 9.50~dfsg-5ubuntu4.2
- 9.50~dfsg-5ubuntu4.3
- 9.50~dfsg-5ubuntu4.4
- 9.50~dfsg-5ubuntu4.5
- 9.50~dfsg-5ubuntu4.6
- 9.50~dfsg-5ubuntu4.7
- 9.50~dfsg-5ubuntu4.8
- 9.50~dfsg-5ubuntu4.9
- 9.50~dfsg-5ubuntu4.10
- 9.50~dfsg-5ubuntu4.11
- Affected ranges
- ECOSYSTEM: < 9.50~dfsg-5ubuntu4.12
Update to 9.50~dfsg-5ubuntu4.12
ghostscript Ubuntu:22.04:LTS
- Versions
- 9.54.0~dfsg1-0ubuntu2
- 9.55.0~dfsg1-0ubuntu4
- 9.55.0~dfsg1-0ubuntu5
- 9.55.0~dfsg1-0ubuntu5.1
- 9.55.0~dfsg1-0ubuntu5.2
- 9.55.0~dfsg1-0ubuntu5.3
- 9.55.0~dfsg1-0ubuntu5.4
- 9.55.0~dfsg1-0ubuntu5.5
- 9.55.0~dfsg1-0ubuntu5.6
- Affected ranges
- ECOSYSTEM: < 9.55.0~dfsg1-0ubuntu5.7
Update to 9.55.0~dfsg1-0ubuntu5.7
ghostscript Ubuntu:24.04:LTS
- Versions
- 10.01.2~dfsg1-0ubuntu2
- 10.01.2~dfsg1-0ubuntu2.1
- 10.02.1~dfsg1-0ubuntu1
- 10.02.1~dfsg1-0ubuntu2
- 10.02.1~dfsg1-0ubuntu5
- 10.02.1~dfsg1-0ubuntu6
- 10.02.1~dfsg1-0ubuntu7
- Affected ranges
- ECOSYSTEM: < 10.02.1~dfsg1-0ubuntu7.1
Update to 10.02.1~dfsg1-0ubuntu7.1
Original sources
- https://bugs.ghostscript.com/show_bug.cgi?id=707662
- https://www.openwall.com/lists/oss-security/2024/07/03/7
- https://codeanlabs.com/blog/research/cve-2024-29510-ghostscript-format-string-exploitation/
- https://www.vicarius.io/vsociety/posts/critical-vulnerability-in-ghostscript-cve-2024-29510
- https://nvd.nist.gov/vuln/detail/CVE-2024-29510