CVE-2024-36110
CVE-2024-36110 · Cross-site scripting in ansibleguy-webui
This page contains facts from public vulnerability sources. Check the original advisory before updating.
ansibleguy-webui is an open source WebUI for using Ansible. Multiple forms in versions < 0.0.21 allowed injection of HTML elements. These are returned to the user after executing job actions and thus evaluated by the browser. These issues have been addressed in version 0.0.21 (0.0.21.post2 on pypi). Users are advised to upgrade. There are no known workarounds for these issues.
CVSS 8.2 · High · EPSS 0.4% · Fix available
- Published
- Updated
Stack: python
Affected products and versions
webui
- Versions
- < 0.0.21: Affected
No fix published
ansibleguy-webui PyPI
- Versions
- 0.0.15
- 0.0.16
- 0.0.17
- 0.0.18
- 0.0.19
- 0.0.20
- Affected ranges
- ECOSYSTEM: < 0.0.21
Update to 0.0.21
Original sources
- https://github.com/ansibleguy/webui/security/advisories/GHSA-927p-xrc2-x2gj
- https://github.com/ansibleguy/webui/issues/44
- https://github.com/ansibleguy/webui/commit/7737b47e7f7ddbfec7b1418c724598363718d522
- https://github.com/ansibleguy/webui/files/15358522/Report.pdf
- https://nvd.nist.gov/vuln/detail/CVE-2024-36110