CVE-2024-37297
CVE-2024-37297 · WooCommerce has a Cross-Site Scripting Vulnerability in checkout & registration forms
This page contains facts from public vulnerability sources. Check the original advisory before updating.
WooCommerce is an open-source e-commerce platform built on WordPress. A vulnerability introduced in WooCommerce 8.8 allows for cross-site scripting. A bad actor can manipulate a link to include malicious HTML & JavaScript content. While the content is not saved to the database, the links may be sent to victims for malicious purposes. The injected JavaScript could hijack content & data stored in the browser, including the session. The URL content is read through the `Sourcebuster.js` library and then inserted without proper sanitization to the classic checkout and registration forms. Versions 8.8.5 and 8.9.3 contain a patch for the issue. As a workaround, one may disable the Order Attribution feature.
CVSS 5.4 · Medium · EPSS 0.5% · Fix available
- Published
- Updated
Stack: php
Affected products and versions
woocommerce
- Versions
- >= 8.8.0, < 8.8.5: Affected
- >= 8.9.0, < 8.9.3: Affected
No fix published
woocommerce/woocommerce Packagist
- Affected ranges
- ECOSYSTEM: ≥ 8.8.0, < 8.8.5
Update to 8.8.5
woocommerce/woocommerce Packagist
- Affected ranges
- ECOSYSTEM: ≥ 8.9.0, < 8.9.3
Update to 8.9.3
Original sources
- https://github.com/woocommerce/woocommerce/security/advisories/GHSA-cv23-q6gh-xfrf
- https://github.com/woocommerce/woocommerce/commit/0e9888305d0cb9557e58f558526ab11cb3bcc4b4
- https://github.com/woocommerce/woocommerce/commit/915e32a42762916b745a7e663c8b69a698da8b67
- https://developer.woocommerce.com/2024/06/10/developer-advisory-xss-vulnerability-8-8-0
- https://nvd.nist.gov/vuln/detail/CVE-2024-37297