p PatchFirst

PatchFirst · Latest vulnerabilities

woocommerce/woocommerce vulnerabilities

Vulnerabilities published for woocommerce/woocommerce in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 5

  1. CVE-2024-37297

    Medium · CVSS 5.4EPSS 0.48%Fix available

    WooCommerce has a Cross-Site Scripting Vulnerability in checkout & registration forms

    WooCommerce is an open-source e-commerce platform built on WordPress. A vulnerability introduced in WooCommerce 8.8 allows for cross-site scripting. A bad actor can manipulate a link to include malicious HTML & JavaScript content. While the content is not saved to the database, the links may be sent to victims for malicious purposes. The injected JavaScript could hijack content & data stored in the browser, including the session. The URL content is read through the `Sourcebuster.js` library and then inserted without proper sanitization to the classic checkout and registration forms. Versions 8.8.5 and 8.9.3 contain a patch for the issue. As a

    • Update to 8.8.5
    • Update to 8.9.3
    Published Updated
  2. CVE-2021-24323

    Medium · CVSS 4.8EPSS 0.74%Fix available

    Woocommerce < 5.2.0 - Authenticated Stored Cross-Site Scripting (XSS)

    When taxes are enabled, the "Additional tax classes" field was not properly sanitised or escaped before being output back in the admin dashboard, allowing high privilege users such as admin to use XSS payloads even when the unfiltered_html is disabled

    • Update to 5.2.0
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →