p PatchFirst

CVE-2024-39324

CVE-2024-39324 · aimeos/ai-admin-graphql improper access control vulnerability allows editors to manage own services

This page contains facts from public vulnerability sources. Check the original advisory before updating.

aimeos/ai-admin-graphql is the Aimeos GraphQL API admin interface. Starting in version 2022.04.1 and prior to versions 2022.10.10, 2023.10.6, and 2024.4.2, improper access control allows a editors to manage own services via GraphQL API which isn't allowed in the JQAdm front end. Versions 2022.10.10, 2023.10.6, and 2024.4.2 contain a patch for the issue.

CVSS 3.8 · Low · EPSS 0.4% · Fix available

Published
Updated

Stack: php

Affected products and versions

  • ai-admin-graphql

    Versions
    • >= 2022.04.1, < 2022.10.10: Affected
    • >= 2023.04.1, < 2023.10.6: Affected
    • = 2024.04.1: Affected

    No fix published

  • aimeos/ai-admin-graphql Packagist

    Versions
    • 2022.10.1
    • 2022.10.2
    • 2022.10.3
    • 2022.10.4
    • 2022.10.5
    • 2022.10.6
    • 2022.10.7
    • 2022.10.8
    • 2022.10.9
    Affected ranges
    • ECOSYSTEM: ≥ 2022.04.1, < 2022.10.10

    Update to 2022.10.10

  • aimeos/ai-admin-graphql Packagist

    Versions
    • 2023.04.1
    • 2023.04.2
    • 2023.04.3
    • 2023.07.1
    • 2023.07.2
    • 2023.10.1
    • 2023.10.2
    • 2023.10.3
    • 2023.10.4
    • 2023.10.5
    Affected ranges
    • ECOSYSTEM: ≥ 2023.04.1, < 2023.10.6

    Update to 2023.10.6

  • aimeos/ai-admin-graphql Packagist

    Versions
    • 2024.04.1
    Affected ranges
    • ECOSYSTEM: ≥ 2024.04.1, < 2024.04.2

    Update to 2024.04.2

Original sources

Check your server →