p PatchFirst

PatchFirst · Latest vulnerabilities

aimeos/ai-admin-graphql vulnerabilities

Vulnerabilities published for aimeos/ai-admin-graphql in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 3

  1. CVE-2024-47173

    Medium · CVSS 5.5EPSS 0.36%Fix available

    Aimeos GraphQL API admin interface denial of service vulnerability in SaaS and marketplace setups

    Aimeos is an e-commerce framework. All SaaS and marketplace setups using the Aimeos GraphQL API admin interface version from 2024.04 up to 2024.07.1 are affected by a potential denial of service attack. Version 2024.07.2 fixes the issue.

    • Update to 2024.07.2
    Published Updated
  2. CVE-2024-39324

    Low · CVSS 3.8EPSS 0.43%Fix available

    aimeos/ai-admin-graphql improper access control vulnerability allows editors to manage own services

    aimeos/ai-admin-graphql is the Aimeos GraphQL API admin interface. Starting in version 2022.04.1 and prior to versions 2022.10.10, 2023.10.6, and 2024.4.2, improper access control allows a editors to manage own services via GraphQL API which isn't allowed in the JQAdm front end. Versions 2022.10.10, 2023.10.6, and 2024.4.2 contain a patch for the issue.

    • Update to 2022.10.10
    • Update to 2023.10.6
    • Update to 2024.04.2
    Published Updated
  3. CVE-2024-39323

    High · CVSS 7.1EPSS 0.44%Fix available

    aimeos/ai-admin-graphql improper access control vulnerability allows an editor to modify admin account

    aimeos/ai-admin-graphql is the Aimeos GraphQL API admin interface. Starting in version 2022.04.01 and prior to versions 2022.10.10, 2023.10.6, and 2024.04.6, an improper access control vulnerability allows an editor to modify and take over an admin account in the back end. Versions 2022.10.10, 2023.10.6, and 2024.04.6 fix this issue.

    • Update to 2022.10.10
    • Update to 2023.10.6
    • Update to 2024.04.6
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →