CVE-2024-39844
CVE-2024-39844
This page contains facts from public vulnerability sources. Check the original advisory before updating.
In ZNC before 1.9.1, remote code execution can occur in modtcl via a KICK.
CVSS 9.8 · Critical · EPSS 3.9% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
znc Debian:12
- Versions
- 1.8.2-3.1
- Affected ranges
- ECOSYSTEM: < 1.8.2-3.1+deb12u1
Update to 1.8.2-3.1+deb12u1
znc Debian:13
- Affected ranges
- ECOSYSTEM: < 1.9.1-1
Update to 1.9.1-1
znc Debian:14
- Affected ranges
- ECOSYSTEM: < 1.9.1-1
Update to 1.9.1-1
znc Ubuntu:Pro:14.04:LTS
- Versions
- 1.0-5
- 1.0-5build1
- 1.2-1
- 1.2-2
- 1.2-3
- 1.2-3build1
- 1.2-3ubuntu0.1
- 1.2-3ubuntu0.1+esm1
- Affected ranges
- ECOSYSTEM: < 1.2-3ubuntu0.1+esm3
Update to 1.2-3ubuntu0.1+esm3
znc Ubuntu:Pro:16.04:LTS
- Versions
- 1.6.1-1
- 1.6.1-1build1
- 1.6.1-2
- 1.6.2-1
- 1.6.2-2
- 1.6.2-2build1
- 1.6.3-1
- 1.6.3-1ubuntu0.1
- 1.6.3-1ubuntu0.2
- Affected ranges
- ECOSYSTEM: < 1.6.3-1ubuntu0.2+esm2
Update to 1.6.3-1ubuntu0.2+esm2
znc Ubuntu:Pro:18.04:LTS
- Versions
- 1.6.5-2build2
- 1.6.5-2build3
- 1.6.5-2build4
- 1.6.5-2build5
- 1.6.6-1
- 1.6.6-1ubuntu0.1
- 1.6.6-1ubuntu0.2
- Affected ranges
- ECOSYSTEM: < 1.6.6-1ubuntu0.2+esm2
Update to 1.6.6-1ubuntu0.2+esm2
znc Ubuntu:Pro:20.04:LTS
- Versions
- 1.7.4-7
- 1.7.4-7build1
- 1.7.5-1
- 1.7.5-2
- 1.7.5-2build1
- 1.7.5-2build2
- 1.7.5-2build3
- 1.7.5-3
- 1.7.5-3build1
- 1.7.5-4
- Affected ranges
- ECOSYSTEM: < 1.7.5-4ubuntu0.1~esm2
Update to 1.7.5-4ubuntu0.1~esm2
znc Ubuntu:22.04:LTS
- Versions
- 1.8.2-2build1
- 1.8.2-2build2
- 1.8.2-2build3
- 1.8.2-2build5
- Affected ranges
- ECOSYSTEM: < 1.8.2-2ubuntu0.1
Update to 1.8.2-2ubuntu0.1
znc Ubuntu:Pro:24.04:LTS
- Versions
- 1.8.2-3.1
- 1.8.2-4
- 1.8.2-4build1
- 1.8.2-4build3
- 1.9.0-2build2
- 1.9.0-2build3
- Affected ranges
- ECOSYSTEM: < 1.9.0-2ubuntu0.1~esm2
Update to 1.9.0-2ubuntu0.1~esm2