p PatchFirst

PatchFirst · Latest vulnerabilities

znc vulnerabilities

Vulnerabilities published for znc in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 18

  1. CVE-2020-11023

    Medium · CVSS 6.9EPSS 84.89%In KEVPublic exploitFix available

    Potential XSS vulnerability in jQuery

    In jQuery versions greater than or equal to 1.0.3 and before 3.5.0, passing HTML containing <option> elements from untrusted sources - even after sanitizing it - to one of jQuery's DOM manipulation methods (i.e. .html(), .append(), and others) may execute untrusted code. This problem is patched in jQuery 3.5.0.

    • Update to 1.10.3-1
    Published Updated
  2. CVE-2020-11022

    Medium · CVSS 6.9EPSS 99.22%Public exploitFix available

    jQuery has a potential XSS vulnerability

    In jQuery starting with 1.12.0 and before 3.5.0, passing HTML from untrusted sources - even after sanitizing it - to one of jQuery's DOM manipulation methods (i.e. .html(), .append(), and others) may execute untrusted code. This problem is patched in jQuery 3.5.0.

    • Update to 1.10.3-1
    Published Updated
  3. CVE-2014-9403

    Not ratedEPSS 2.16%Fix available

    CVE-2014-9403

    The CWebAdminMod::ChanPage function in modules/webadmin.cpp in ZNC before 1.4 allows remote authenticated users to cause a denial of service (NULL pointer dereference and crash) by adding a channel with the same name as an existing channel but without the leading # character, related to a "use-after-delete" error.

    • Update to 1.2-4
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →