p PatchFirst

CVE-2024-42415

CVE-2024-42415

This page contains facts from public vulnerability sources. Check the original advisory before updating.

An integer overflow vulnerability exists in the Compound Document Binary File format parser of v1.14.52 of the GNOME Project G Structured File Library (libgsf). A specially crafted file can result in an integer overflow that allows for a heap-based buffer overflow when processing the sector allocation table. This can lead to arbitrary code execution. An attacker can provide a malicious file to trigger this vulnerability.

CVSS 8.4 · High · EPSS 0.5% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • g structured file library (libgsf)

    Versions
    • 1.14.52: Affected

    No fix published

  • libgsf Debian:12

    Versions
    • 1.14.50-1
    Affected ranges
    • ECOSYSTEM: < 1.14.50-1+deb12u1

    Update to 1.14.50-1+deb12u1

  • libgsf Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.14.52-1.1

    Update to 1.14.52-1.1

  • libgsf Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.14.52-1.1

    Update to 1.14.52-1.1

  • libgsf Ubuntu:14.04:LTS

    Versions
    • 1.14.27-2ubuntu1
    • 1.14.27-2ubuntu2
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • libgsf Ubuntu:16.04:LTS

    Versions
    • 1.14.34-1
    • 1.14.34-2
    • 1.14.35-1
    • 1.14.36-1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • libgsf Ubuntu:18.04:LTS

    Versions
    • 1.14.41-1
    • 1.14.41-2
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • libgsf Ubuntu:20.04:LTS

    Versions
    • 1.14.46-1
    Affected ranges
    • ECOSYSTEM: < 1.14.46-1ubuntu0.1

    Update to 1.14.46-1ubuntu0.1

  • libgsf Ubuntu:22.04:LTS

    Versions
    • 1.14.47-1build1
    • 1.14.47-1build2
    Affected ranges
    • ECOSYSTEM: < 1.14.47-1ubuntu0.1

    Update to 1.14.47-1ubuntu0.1

  • libgsf Ubuntu:24.04:LTS

    Versions
    • 1.14.50-1
    • 1.14.51-1
    • 1.14.51-2
    • 1.14.51-2build1
    • 1.14.51-2build2
    Affected ranges
    • ECOSYSTEM: < 1.14.51-2ubuntu0.1

    Update to 1.14.51-2ubuntu0.1

Original sources

Check your server →