p PatchFirst

PatchFirst · Latest vulnerabilities

libgsf vulnerabilities

Vulnerabilities published for libgsf in the last 30 days: 1. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 3

  1. CVE-2026-116124

    Medium · CVSS 5.3EPSS 0.43%No fix published

    GNOME libgsf OLE2 gsf-infile-msole.c ole_info_read_metabat heap-based overflow

    A security vulnerability has been detected in GNOME libgsf up to 1.14.60. The impacted element is the function ole_info_read_metabat of the file gsf/gsf-infile-msole.c of the component OLE2 Parser. The manipulation leads to heap-based buffer overflow. The attack can be initiated remotely. The identifier of the patch is a8e25560b74f84c3f86df6ca0ac59195fa5af68a. It is recommended to apply a patch to fix this issue.

    Published Updated
  2. CVE-2024-42415

    High · CVSS 8.4EPSS 0.46%Fix available

    CVE-2024-42415

    An integer overflow vulnerability exists in the Compound Document Binary File format parser of v1.14.52 of the GNOME Project G Structured File Library (libgsf). A specially crafted file can result in an integer overflow that allows for a heap-based buffer overflow when processing the sector allocation table. This can lead to arbitrary code execution. An attacker can provide a malicious file to trigger this vulnerability.

    • Update to 1.14.47-1ubuntu0.1
    Published Updated
  3. CVE-2024-36474

    High · CVSS 8.4EPSS 0.4%Fix available

    CVE-2024-36474

    An integer overflow vulnerability exists in the Compound Document Binary File format parser of the GNOME Project G Structured File Library (libgsf) version v1.14.52. A specially crafted file can result in an integer overflow when processing the directory from the file that allows for an out-of-bounds index to be used when reading and writing to an array. This can lead to arbitrary code execution. An attacker can provide a malicious file to trigger this vulnerability.

    • Update to 1.14.47-1ubuntu0.1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →