p PatchFirst

CVE-2024-43407

CVE-2024-43407 · Code Snippet GeSHi plugin has reflected cross-site scripting (XSS) vulnerability

This page contains facts from public vulnerability sources. Check the original advisory before updating.

CKEditor4 is an open source what-you-see-is-what-you-get HTML editor. A potential vulnerability has been discovered in CKEditor 4 Code Snippet GeSHi plugin. The vulnerability allowed a reflected XSS attack by exploiting a flaw in the GeSHi syntax highlighter library hosted by the victim. The GeSHi library was included as a vendor dependency in CKEditor 4 source files. In a specific scenario, an attacker could craft a malicious script that could be executed by sending a request to the GeSHi library hosted on a PHP web server. The GeSHi library is no longer actively maintained. Due to the lack of ongoing support and updates, potential security vulnerabilities have been identified with its continued use. To mitigate these risks and enhance the overall security of the CKEditor 4, we have decided to completely remove the GeSHi library as a dependency. This change aims to maintain a secure environment and reduce the risk of any security incidents related to outdated or unsupported software. The fix is be available in version 4.25.0-lts.

CVSS 6.1 · Medium · EPSS 0.4% · Fix available

Published
Updated

Stack: system · php · node

Affected products and versions

  • ckeditor4

    Versions
    • < 4.25.0-lts: Affected

    No fix published

  • ckeditor Debian:12

    Versions
    • 4.19.1+dfsg-1
    • 4.22.1+dfsg-1
    • 4.22.1+dfsg1-2
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • ckeditor4 npm

    Affected ranges
    • SEMVER: < 4.25.0

    Update to 4.25.0

  • ckeditor/ckeditor Packagist

    Versions
    • 4.10.0
    • 4.10.1
    • 4.11.0
    • 4.11.1
    • 4.11.2
    • 4.11.3
    • 4.11.4
    • 4.12.0
    • 4.12.1
    • 4.13.0
    • 4.13.1
    • 4.14.0
    • 4.14.1
    • 4.15.0
    • 4.15.1
    • 4.16.0
    • 4.16.1
    • 4.16.2
    • 4.17.0
    • 4.17.1
    • 4.17.2
    • 4.18.0
    • 4.19.0
    • 4.19.1
    • 4.20.0
    • 4.20.1
    • 4.20.2
    • 4.21.0
    • 4.22.0
    • 4.22.1
    • 4.23.0
    • 4.24.0
    • 4.3.3
    • 4.3.4
    • 4.3.5
    • 4.4.0
    • 4.4.1
    • 4.4.2
    • 4.4.3
    • 4.4.4
    • 4.4.5
    • 4.4.6
    • 4.4.7
    • 4.4.8
    • 4.5.0
    • 4.5.1
    • 4.5.10
    • 4.5.11
    • 4.5.2
    • 4.5.3
    • 4.5.4
    • 4.5.5
    • 4.5.6
    • 4.5.7
    • 4.5.8
    • 4.5.9
    • 4.6.0
    • 4.6.1
    • 4.6.2
    • 4.7.0
    • 4.7.1
    • 4.7.2
    • 4.7.3
    • 4.8.0
    • 4.9.0
    • 4.9.1
    • 4.9.2
    Affected ranges
    • ECOSYSTEM: < 4.25.0

    Update to 4.25.0

  • geshi Ubuntu:16.04:LTS

    Versions
    • 1.0.8.11-2
    • 1.0.8.11-2ubuntu1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • geshi Ubuntu:18.04:LTS

    Versions
    • 1.0.8.11-2.1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • geshi Ubuntu:20.04:LTS

    Versions
    • 1.0.8.11-3
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • geshi Ubuntu:22.04:LTS

    Versions
    • 1.0.9.1-1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • geshi Ubuntu:24.04:LTS

    Versions
    • 1.0.9.1-1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • geshi Ubuntu:25.10

    Versions
    • 1.0.9.1-1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • geshi Ubuntu:26.10

    Versions
    • 1.0.9.1-1build1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • geshi Ubuntu:26.04:LTS

    Versions
    • 1.0.9.1-1
    • 1.0.9.1-1build1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →