p PatchFirst

PatchFirst · Latest vulnerabilities

ckeditor/ckeditor vulnerabilities

Vulnerabilities published for ckeditor/ckeditor in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 4

  1. CVE-2024-43407

    Medium · CVSS 6.1EPSS 0.45%Fix available

    Code Snippet GeSHi plugin has reflected cross-site scripting (XSS) vulnerability

    CKEditor4 is an open source what-you-see-is-what-you-get HTML editor. A potential vulnerability has been discovered in CKEditor 4 Code Snippet GeSHi plugin. The vulnerability allowed a reflected XSS attack by exploiting a flaw in the GeSHi syntax highlighter library hosted by the victim. The GeSHi library was included as a vendor dependency in CKEditor 4 source files. In a specific scenario, an attacker could craft a malicious script that could be executed by sending a request to the GeSHi library hosted on a PHP web server. The GeSHi library is no longer actively maintained. Due to the lack of ongoing support and updates, potential security

    • Update to 4.25.0
    Published Updated
  2. CVE-2024-24815

    Medium · CVSS 6.1EPSS 0.71%Fix available

    CKEditor4 Cross-site scripting (XSS) vulnerability caused by incorrect CDATA detection

    CKEditor4 is an open source what-you-see-is-what-you-get HTML editor. A cross-site scripting vulnerability has been discovered in the core HTML parsing module in versions of CKEditor4 prior to 4.24.0-lts. It may affect all editor instances that enabled full-page editing mode or enabled CDATA elements in Advanced Content Filtering configuration (defaults to `script` and `style` elements). The vulnerability allows attackers to inject malformed HTML content bypassing Advanced Content Filtering mechanism, which could result in executing JavaScript code. An attacker could abuse faulty CDATA content detection and use it to prepare an intentional at

    • Update to 4.24.0
    Published Updated
  3. CVE-2021-41165

    High · CVSS 8.2EPSS 1.57%Fix available

    HTML comments vulnerability allowing to execute JavaScript code

    CKEditor4 is an open source WYSIWYG HTML editor. In affected version a vulnerability has been discovered in the core HTML processing module and may affect all plugins used by CKEditor 4. The vulnerability allowed to inject malformed comments HTML bypassing content sanitization, which could result in executing JavaScript code. It affects all users using the CKEditor 4 at version < 4.17.0. The problem has been recognized and patched. The fix will be available in version 4.17.0.

    • Update to 4.17.0
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →