CVE-2024-43411
CVE-2024-43411 · CKEditor4 has a low risk cross-site scripting (XSS) vulnerability from domain takeover
This page contains facts from public vulnerability sources. Check the original advisory before updating.
CKEditor4 is an open source what-you-see-is-what-you-get HTML editor. A theoretical vulnerability has been identified in CKEditor 4.22 (and above). In a highly unlikely scenario where an attacker gains control over the https://cke4.ckeditor.com domain, they could potentially execute an attack on CKEditor 4 instances. The issue impacts only editor instances with enabled version notifications. Please note that this feature is disabled by default in all CKEditor 4 LTS versions. Therefore, if you use CKEditor 4 LTS, it is highly unlikely that you are affected by this vulnerability. If you are unsure, please contact us. The fix is available in version 4.25.0-lts.
CVSS 3.1 · Low · EPSS 0.4% · Fix available
- Published
- Updated
Affected products and versions
ckeditor4
- Versions
- >= 4.22.0, < 4.25.0-lts: Affected
No fix published
ckeditor4 npm
- Affected ranges
- SEMVER: ≥ 4.22.0, < 4.25.0
Update to 4.25.0
ldap-account-manager Ubuntu:16.04:LTS
- Versions
- 4.9-1
- 5.1-1
- 5.2-1
- 5.2-1ubuntu1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
request-tracker4 Ubuntu:16.04:LTS
- Versions
- 4.2.11-2
- 4.2.12-3
- 4.2.12-4
- 4.2.12-5
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
ckeditor3 Ubuntu:18.04:LTS
- Versions
- 3.6.6.1+dfsg-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
ldap-account-manager Ubuntu:18.04:LTS
- Versions
- 5.7-1
- 6.1-1
- 6.2-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
request-tracker4 Ubuntu:Pro:18.04:LTS
- Versions
- 4.4.1-5
- 4.4.2-1
- 4.4.2-2
- 4.4.2-2ubuntu0.1~esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
ckeditor3 Ubuntu:20.04:LTS
- Versions
- 3.6.6.1+dfsg-3
- 3.6.6.1+dfsg-4
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
ldap-account-manager Ubuntu:20.04:LTS
- Versions
- 6.7-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
request-tracker4 Ubuntu:20.04:LTS
- Versions
- 4.4.3-2
- 4.4.3-2+deb10u3build0.20.04.1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
ckeditor3 Ubuntu:22.04:LTS
- Versions
- 3.6.6.1+dfsg-7
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
ldap-account-manager Ubuntu:22.04:LTS
- Versions
- 7.5-1
- 7.7-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
request-tracker4 Ubuntu:22.04:LTS
- Versions
- 4.4.4+dfsg-2ubuntu1
- 4.4.4+dfsg-2ubuntu1.22.04.1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
ckeditor3 Ubuntu:24.04:LTS
- Versions
- 3.6.6.1+dfsg-7
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
ldap-account-manager Ubuntu:24.04:LTS
- Versions
- 8.3-1
- 8.5-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
request-tracker4 Ubuntu:24.04:LTS
- Versions
- 4.4.4+dfsg-2ubuntu1
- 4.4.4+dfsg-2ubuntu2
- 4.4.7+dfsg-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
ckeditor Ubuntu:Pro:24.04:LTS
- Versions
- 4.22.1+dfsg1-2
- 4.22.1+dfsg1-2ubuntu0.24.04.1~esm1
- 4.22.1+dfsg1-2ubuntu0.24.04.1~esm2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
ckeditor Ubuntu:25.10
- Versions
- 4.22.1+dfsg1-2ubuntu1
- 4.22.1+dfsg1-2ubuntu1.1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
ldap-account-manager Ubuntu:25.10
- Versions
- 9.0-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
request-tracker4 Ubuntu:25.10
- Versions
- 4.4.7+dfsg-4syncable1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
ldap-account-manager Ubuntu:26.04:LTS
- Versions
- 9.0-1
- 9.0-1build1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
request-tracker4 Ubuntu:26.04:LTS
- Versions
- 4.4.7+dfsg-4syncable1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published