p PatchFirst

PatchFirst · Latest vulnerabilities

ckeditor vulnerabilities

Vulnerabilities published for ckeditor in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 6

  1. CVE-2026-28343

    Medium · CVSS 6.4EPSS 0.28%No fix published

    CKEditor: Cross-site scripting (XSS) in the HTML Support package

    CKEditor 5 is a modern JavaScript rich-text editor with an MVC architecture. Starting in version 29.0.0 and prior to version 47.6.0, a cross-site scripting (XSS) vulnerability has been discovered in the General HTML Support feature. This vulnerability could be triggered by inserting specially crafted markup, leading to unauthorized JavaScript code execution, if the editor instance used an unsafe General HTML Support configuration. This issue has been patched in version 47.6.0.

    Published Updated
  2. CVE-2025-25299

    Low · CVSS 2.3EPSS 0.6%No fix published

    Cross-site scripting (XSS) in the real-time collaboration package

    CKEditor 5 is a modern JavaScript rich-text editor with an MVC architecture. During a recent internal audit, a Cross-Site Scripting (XSS) vulnerability was discovered in the CKEditor 5 real-time collaboration package. This vulnerability affects user markers, which represent users' positions within the document. It can lead to unauthorized JavaScript code execution, which might happen with a very specific editor and token endpoint configuration. This vulnerability affects only installations with Real-time collaborative editing enabled. The problem has been recognized and patched. The fix is available in version 44.2.1 (and above). Users are ad

    Published Updated
  3. CVE-2024-43411

    Low · CVSS 3.1EPSS 0.43%No fix published

    CKEditor4 has a low risk cross-site scripting (XSS) vulnerability from domain takeover

    CKEditor4 is an open source what-you-see-is-what-you-get HTML editor. A theoretical vulnerability has been identified in CKEditor 4.22 (and above). In a highly unlikely scenario where an attacker gains control over the https://cke4.ckeditor.com domain, they could potentially execute an attack on CKEditor 4 instances. The issue impacts only editor instances with enabled version notifications. Please note that this feature is disabled by default in all CKEditor 4 LTS versions. Therefore, if you use CKEditor 4 LTS, it is highly unlikely that you are affected by this vulnerability. If you are unsure, please contact us. The fix is available in ver

    Published Updated
  4. CVE-2024-24816

    Medium · CVSS 6.1EPSS 1.65%No fix published

    Cross-site scripting (XSS) vulnerability in samples with enabled the preview feature

    CKEditor4 is an open source what-you-see-is-what-you-get HTML editor. A cross-site scripting vulnerability vulnerability has been discovered in versions prior to 4.24.0-lts in samples that use the `preview` feature. All integrators that use these samples in the production code can be affected. The vulnerability allows an attacker to execute JavaScript code by abusing the misconfigured preview feature. It affects all users using the CKEditor 4 at version < 4.24.0-lts with affected samples used in a production environment. A fix is available in version 4.24.0-lts.

    Published Updated
  5. CVE-2024-24815

    Medium · CVSS 6.1EPSS 0.71%No fix published

    CKEditor4 Cross-site scripting (XSS) vulnerability caused by incorrect CDATA detection

    CKEditor4 is an open source what-you-see-is-what-you-get HTML editor. A cross-site scripting vulnerability has been discovered in the core HTML parsing module in versions of CKEditor4 prior to 4.24.0-lts. It may affect all editor instances that enabled full-page editing mode or enabled CDATA elements in Advanced Content Filtering configuration (defaults to `script` and `style` elements). The vulnerability allows attackers to inject malformed HTML content bypassing Advanced Content Filtering mechanism, which could result in executing JavaScript code. An attacker could abuse faulty CDATA content detection and use it to prepare an intentional at

    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →