CVE-2024-52810
CVE-2024-52810 · Prototype Pollution in @intlify/shared >=9.7.0 <= 10.0.4
This page contains facts from public vulnerability sources. Check the original advisory before updating.
@intlify/shared is a shared library for the intlify project. The latest version of @intlify/shared (10.0.4) is vulnerable to Prototype Pollution through the entry function(s) lib.deepCopy. An attacker can supply a payload with Object.prototype setter to introduce or modify properties within the global prototype chain, causing denial of service (DoS) as the minimum consequence. Moreover, the consequences of this vulnerability can escalate to other injection-based attacks, depending on how the library integrates within the application. For instance, if the polluted property propagates to sensitive Node.js APIs (e.g., exec, eval), it could enable an attacker to execute arbitrary commands within the application's context. This issue has been addressed in versions 9.14.2, and 10.0.5. Users are advised to upgrade. There are no known workarounds for this vulnerability.
CVSS 6.9 · Medium · EPSS 0.8% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
vue-i18n
- Versions
- >= 9.7.0, < 9.14.2: Affected
- >= 10.0.0, < 10.0.5: Affected
No fix published
@intlify/shared npm
- Affected ranges
- SEMVER: ≥ 9.7.0, < 9.14.2
Update to 9.14.2
@intlify/vue-i18n-core npm
- Affected ranges
- SEMVER: ≥ 9.7.0, < 9.14.2
Update to 9.14.2
vue-i18n npm
- Affected ranges
- SEMVER: ≥ 9.7.0, < 9.14.2
Update to 9.14.2
petite-vue-i18n npm
- Affected ranges
- SEMVER: ≥ 10.0.0, < 10.0.5
Update to 10.0.5
@intlify/shared npm
- Affected ranges
- SEMVER: ≥ 10.0.0, < 10.0.5
Update to 10.0.5
@intlify/vue-i18n-core npm
- Affected ranges
- SEMVER: ≥ 10.0.0, < 10.0.5
Update to 10.0.5
vue-i18n npm
- Affected ranges
- SEMVER: ≥ 10.0.0, < 10.0.5
Update to 10.0.5