p PatchFirst

PatchFirst · Latest vulnerabilities

@intlify/shared vulnerabilities

Vulnerability published for @intlify/shared in the last 30 days: 1. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 2

  1. CVE-2026-118257

    High · CVSS 7.2EPSS 0.27%Public exploitFix available

    Vue I18n: escapeParameter does not prevent XSS through srcdoc in translation messages

    Vue I18n is the internationalization plugin for Vue.js. From 11.1.10 until 11.4.14 and from 12.0.0-alpha.4 until 12.0.0-alpha.5, sanitizeTranslatedHtml() escapes markup and event-handler text inside an iframe srcdoc value but leaves the srcdoc attribute active. Browsers decode the character references and parse the value as a same-origin nested HTML document, allowing attacker-controlled parameters or translation content placed in srcdoc to execute script when applications enable escapeParameter and render translations as HTML through v-html. Versions 9.14.5 and 10.0.8 are also affected and are no longer supported, while i18n-t rendering is n

    • Update to 11.4.14
    • Update to 12.0.0-alpha.5
    Published Updated
  2. CVE-2024-52810

    Medium · CVSS 6.9EPSS 0.77%Fix available

    Prototype Pollution in @intlify/shared >=9.7.0 <= 10.0.4

    @intlify/shared is a shared library for the intlify project. The latest version of @intlify/shared (10.0.4) is vulnerable to Prototype Pollution through the entry function(s) lib.deepCopy. An attacker can supply a payload with Object.prototype setter to introduce or modify properties within the global prototype chain, causing denial of service (DoS) as the minimum consequence. Moreover, the consequences of this vulnerability can escalate to other injection-based attacks, depending on how the library integrates within the application. For instance, if the polluted property propagates to sensitive Node.js APIs (e.g., exec, eval), it could enabl

    • Update to 10.0.5
    • Update to 9.14.2
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →