p PatchFirst

CVE-2025-1025

CVE-2025-1025

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Versions of the package cockpit-hq/cockpit before 2.4.1 are vulnerable to Arbitrary File Upload where an attacker can use different extension to bypass the upload filter.

CVSS 8.7 · High · EPSS 18.9% · Public exploit · Fix available

Published
Updated

Stack: php

Affected products and versions

  • cockpit-hq/cockpit

    Versions
    • ≥ 0, < 2.4.1: Affected (semver)

    Update to 2.4.1

  • cockpit-hq/cockpit Packagist

    Versions
    • 2.0.0
    • 2.0.1
    • 2.0.2
    • 2.1.0
    • 2.1.1
    • 2.1.2
    • 2.2.0
    • 2.2.1
    • 2.2.2
    • 2.3.0
    • 2.3.1
    • 2.3.2
    • 2.3.3
    • 2.3.4
    • 2.3.5
    • 2.3.6
    • 2.3.7
    • 2.3.8
    • 2.3.9
    • 2.4.0
    Affected ranges
    • ECOSYSTEM: < 2.4.1

    Update to 2.4.1

Original sources

Check your server →