p PatchFirst

PatchFirst · Latest vulnerabilities

cockpit-hq/cockpit vulnerabilities

Vulnerabilities published for cockpit-hq/cockpit in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 26

  1. CVE-2026-23695

    Medium · CVSS 5.1EPSS 0.14%No fix published

    Cockpit CMS 2.14.0 Stored XSS via Set Field Display Template

    Cockpit CMS through version 2.14.0, patched in commit 72a83fc, contains a stored cross-site scripting vulnerability in the Set field type's Display template option, where the template string is processed by the $interpolate function using new Function() and rendered via Vue's v-html directive without sanitization. An attacker with content/:models/manage permission can inject arbitrary JavaScript into the Display template, which executes in the browser of any user viewing the collection items list.

    Published Updated
  2. CVE-2026-38991

    High · CVSS 8.8EPSS 0.38%Fix available

    CVE-2026-38991

    Cockpit 2.13.5 and earlier is affected by a misconfiguration within the Bucket component _isFileTypeAllowed function where a specially crafted filename bypasses an extension filter. This allows an authenticated attacker to rename arbitrary files with the .php file extension enabling arbitrary code to be executed on the underlying server.

    • Update to 2.14.0
    Published Updated
  3. CVE-2026-6626

    Medium · CVSS 5.3EPSS 0.23%Fix available

    Cockpit-HQ Cockpit Asset Handler/Aggregate data query logic injection

    A vulnerability was detected in Cockpit-HQ Cockpit up to 2.13.5. Affected by this issue is some unknown functionality of the component Asset Handler/Aggregate Handler. The manipulation results in improper neutralization of special elements in data query logic. It is possible to launch the attack remotely. The exploit is now public and may be used. The vendor was contacted early about this disclosure but did not respond in any way.

    • Update to 2.14.0
    Published Updated
  4. CVE-2026-31891

    High · CVSS 7.7EPSS 0.4%Fix available

    Cockpit CMS has SQL Injection in MongoLite Aggregation Optimizer via toJsonExtractRaw()

    Cockpit is a headless content management system. Any Cockpit CMS instance running version 2.13.4 or earlier with API access enabled is potentially affected by a a SQL Injection vulnerability in the MongoLite Aggregation Optimizer. Any deployment where the `/api/content/aggregate/{model}` endpoint is publicly accessible or reachable by untrusted users may be vulnerable, and attackers in possession of a valid read-only API key (the lowest privilege level) can exploit this vulnerability — no admin access is required. An attacker can inject arbitrary SQL via unsanitized field names in aggregation queries, bypass the `_state=1` published-content f

    • Update to 2.13.5
    Published Updated
  5. CVE-2025-7053

    Medium · CVSS 5.1EPSS 0.35%Fix available

    Cockpit save cross site scripting

    A vulnerability was found in Cockpit up to 2.11.3. It has been rated as problematic. This issue affects some unknown processing of the file /system/users/save. The manipulation of the argument name/email leads to cross site scripting. The attack may be initiated remotely. Upgrading to version 2.11.4 is able to address this issue. The patch is named bdcd5e3bc651c0839c7eea807f3eb6af856dbc76. It is recommended to upgrade the affected component. The vendor was contacted early about this disclosure and acted very professional. A patch and new release was made available very quickly.

    • Update to 2.11.4
    Published Updated
  6. CVE-2024-4825

    Critical · CVSS 9.8EPSS 0.72%Fix available

    Unrestricted Upload of File with Dangerous Type vulnerability on Cockpit CMS from Agentejo

    A vulnerability has been discovered in Agentejo Cockpit CMS v0.5.5 that consists in an arbitrary file upload in ‘/media/api’ parameter via post request. An attacker could upload files to the server, compromising the entire infrastructure.

    • Update to 2.7.0
    Published Updated
  7. CVE-2024-2001

    Medium · CVSS 5.5EPSS 0.32%No fix published

    Cross-Site Scripting vulnerability in Cockpit CMS

    A Cross-Site Scripting vulnerability in Cockpit CMS affecting version 2.7.0. This vulnerability could allow an authenticated user to upload an infected PDF file and store a malicious JavaScript payload to be executed when the file is uploaded.

    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →